Mouse over a <select> causes plug-in to re-paint

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Vlad Alexander, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050802 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050802 Firefox/1.0+

If you have a listbox (<select>) above a plug-in, moving the cursor over the
listbox cause the plug-in to re-paint. It's as though moving the cursor over the
listbox causes it to open momentarily and if the list overlaps a plug-in, the
plug-in re-paints. When plug-in re-paints, the plug-in area flickers. Not only
is this annoying for users but is also an accessibility issue for users who are
sensitive to screen flickering.

Reproducible: Always

Steps to Reproduce:
1. Create a <select> with lots of <options> and put it before a plug-in (<object>).
2. Move cursor over the <select> list.

Actual Results:  
When the mouse moves over the listbox, something opens and closes over the listbox. 

Expected Results:  
Nothing should open / close over the listbox when the mouse is moved over it.
It sounds like we're invalidating the area covered by the combobox dropdown when
the user mousesover a combobox <select>, even when the dropdown is hidden. I can
see how that could happen and it should be relatively simple to fix.
I can't reproduce having the area invalidate in GTK2 (but without the plugin, of
course). Could this be Windows only?
(Reporter)

Comment 3

13 years ago
It's okay on the Mac so it could be a Windows only problem.
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Version: unspecified → 1.0 Branch
(Reporter)

Comment 5

8 years ago
The problem is reproducible in FF 3.6.3. Although the plugin area repains (flashes) only the first time the cursor is moved over the list box. I am okay if you mark this bug as wontfix.

Updated

8 years ago
Version: 1.0 Branch → 3.6 Branch
Are you seeing this issue with Firefox 4?
(Reporter)

Comment 7

7 years ago
Cannot reproduce with FF 4. Feel free to close this bug.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.