If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tab bar removed if accidentally close last tab, even if mask tabs NOT selected in preferences

RESOLVED DUPLICATE of bug 156082

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 156082
12 years ago
12 years ago

People

(Reporter: andré, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050716
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050716

In preferences> navigator> tabs, there is an option "mask tab bar if only one
open".  If this is UNCHECKED, one would expect that the tab bar remains open.
However, this setting is ignored if one accidentally closes the last tab.


Reproducible: Always

Steps to Reproduce:
1. Under preferences> navigator> tabs:  uncheck "mask tab bar if only one open".
 Select OK to save when exit preferences.
2. Press the left icon in the tab bar several times, to open several tabs.
3. Press the "X" at the right of the tab bar, until only one tab remains.
Press the "X" one more time. 

Actual Results:  
The tab bar is defined by step 1.
Numerous tabs are opened in step 2.
The tabs are closed in step 3.
When only one tab remains, pressing "X" removes the tab bar.

Expected Results:  
When only one tab remains, pressing "X" should have no effect, if preferences>
navigator> tabs> "mask tab bar if only one open" is UNCHECKED.
(The default is - or was - checked.)

Workaround = open menu "display> tool_bars", click "tab_bar" so the check mark
reappears.
It is more than a trivial problem for those who regularly use tabs.
Effectively, the preference setting for "mask tab bar if only one open" is
ignored.  (And assumed to be checked.)
Occurs with both classic and modern themes, present for a long time.

Comment 1

12 years ago
Related to Core bug 150099?

Comment 2

12 years ago
Yes, see  bug 150099 comment 19. That was by design. But you are not the only
one who does not prefer this.

*** This bug has been marked as a duplicate of 156082 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.