Clicking on gmail link in history does not request login.

RESOLVED DUPLICATE of bug 304818

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 304818
13 years ago
10 years ago

People

(Reporter: Amy Brookhouser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When clicking on any gmail history item, Mozilla does not request a login no
matter how long since you last logged in. Anyone opening the browser can read
private email and access the account. Does not occur with (sorry, gak) IE.

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla.
2.Go to view/sidebar/history
3.Click on any gmail history item and read all my naughty secrets!

Actual Results:  
Was able to read and access account without ID or password. This is NOT a
password I have allowed Mozilla to save. (Checked password manager to ensure
that I'm not being a dumbass)

Expected Results:  
After closing session, Mozilla should require a password to allow one into the
account.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 304818 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.