Orange feeds icon in location bar always looks the same but has unpredictable behaviour when clicked

REOPENED
Unassigned

Status

()

REOPENED
13 years ago
6 years ago

People

(Reporter: 32768, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change], URL)

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050812 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050812 Firefox/1.0+

On a site which has live feeds available (orange icon), clicking the orange icon
in the location bar has a different effect depending on whether the site has one
feed or multiple feeds.

There is no way to tell if the site has only one feed before clicking the
button.  Therefore, there is no way for the user to know whether they will see a
drop-down menu as they are accustomed to, or if they will be taken directly to a
feed, until they click the icon.

This is a usability bug - if the icon looks the same, single-clicking the icon
should always behave the same.

As instructed in Bug 304679 I am opening a new bug to propose the possibility of
changing the appearance of the icon to make it clearer what will happen when the
icon is clicked.

Bug 304679 proposed that the behaviour when clicking the icon should always be
the same.  That bug was wontfixed unfortunately.

As seen in Bug 304679 Comment 1, this bug indicates that the icon needs to be
changed to give the user prior warning that the behaviour of the icon is
sometimes different.

If clicking the icon is going to have an unexpected effect depending on
circumstances which the user is not aware of, the user should be warned of this
different effect so that they are not surprised when they click on the icon and
something unexpected happens.  The icon should look different when there are
multiple feeds.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.sitepoint.com/ which has multiple feeds
2. Click the orange feeds button in location bar

3. Navigate to http://www.planet-php.net/ which has one feed
4. Click the orange feeds button in location bar
Actual Results:  
Step 2 results in a popup menu appearing telling me which feeds are available.

Step 4 results in the site's feed loading in the main window replacing the
current web page, with no intermediate popup


Expected Results:  
It should be clear and consistent what is going to happen when clicking on the
icon, _before_ it is clicked.

Comment 1

13 years ago
(In reply to comment #0)
> Expected Results:  
> It should be clear and consistent what is going to happen when clicking on the
> icon, _before_ it is clicked.

i guess the logic is logic: click means go to the RSS feed. If there happen to
be more then give the choice which one should be used. Minimum number of click
events?
*** Bug 304862 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(from bug 304862 comment 0 ...)

The behaviour of the feedview icon in the URL bar is different depending on  
the number of available feeds. This is as-designed, and results in a minimum 
number of mouse clicks in order for a user to get to the feed (and bug 304679 
was marked WONTFIX accordingly.) However, there's no indication to users that 
the behaviour of the button will be different, which is important, as bug    
304843 points out that the click response will either be full-click (for 
single feeds) or on mouse down (for multiple feeds, in order to bring up the 
drop-down menu from which a feed can be selected.) 

This bug is for a new icon that represents multiple available feeds. It should
be as similar to the RSS icon as possible. I'd suggest trying to avoid just
adding a down arrow, as that 1) collides with our existing icon for a
livebookmark feed in WinXP, and 2) adds a drop-down arrow right beside the
drop-down arrow for the URL bar. Instead, perhaps we could get a cascade of 2 or
3 RSS icons from upper-left to bottom-right?
Blocks: 303848

Comment 4

13 years ago
Maybe add a second icon for if there is 2 or more feeds, and have it look like
the feed icons are slightly "stacked"?  
Well, that's two people suggesting the same thing. Works for me. I'm short on
graphics editing software at the moment or else I'd whip this up.
Created attachment 192900 [details]
prelim icon

Suggestions? Criticism?

Comment 7

13 years ago
Created attachment 192904 [details]
Icon 1

http://burntelectrons.org/media/livemarksicon/multilivemarksicondemo.html

I tried three stacked, bt you lost so much detail it just looked awful, so I've
tried stacking two here, in two different arrangements. Will attach the second
icon next comment.

Comment 8

13 years ago
Created attachment 192905 [details]
Icon 2

Comment 9

13 years ago
Grey: thank you for your help!

My 2cents: icon 2 looks like it's a single icon, that is, it isn't really clear
that it is multiple feed icons that are stacked.

Therefore i prefer icon 1, but slightly different. Most icons like that wil show
left-to-right + top-to-bottom progress, meaning that the newest part of the icon
should lie in the bottom right, and not the top right?



 

Comment 10

13 years ago
I tried that arrangement, but it winds up looking like one long oddly-shaped
icon because it's also echoing the "direction" of the little lines radiating
from the dot. Same thing with three icons, it just looks like a jumble versus
separate icons.

Maybe when people upgrade to 300DPI displays, we can finally get decent canvases
to draw icons on. ;)

Comment 11

13 years ago
Created attachment 192926 [details]
Icon 3

per Patrick's suggestions

Comment 12

13 years ago
Not to say this is bad (it isn't), but might I suggest an arrow (pointing
downwards) after the current icon, if there are multiple feeds.
Something like:
teh_icon[multiple]:after {
  contant: url(the-same-arrow-down-as-used-in-scrollbars);
}

Comment 13

13 years ago
(In reply to comment #12)
> Not to say this is bad (it isn't), but might I suggest an arrow (pointing
> downwards) after the current icon, if there are multiple feeds.
> Something like:
> teh_icon[multiple]:after {
>   contant: url(the-same-arrow-down-as-used-in-scrollbars);
> }


see comment 3 and comment 4
"I'd suggest trying to avoid just adding a down arrow, as that 1) collides with
our existing icon for a livebookmark feed in WinXP, and 2) adds a drop-down
arrow right beside the drop-down arrow for the URL bar. Instead, perhaps we
could get a cascade of 2 or 3 RSS icons from upper-left to bottom-right?"
(In reply to comment #11)
> Created an attachment (id=192926) [edit]
> Icon 3
> per Patrick's suggestions

Looks good to me. I think that while the up-and-right layout mimics the radio
waves, the down-and-right layout brings the eye towards the drop-down menu that
will eventually appar.

So icon looks to be ready. Now we need the patch that puts it in!

Comment 15

13 years ago
Created attachment 193007 [details]
Icon 4

drop-shadow direction corrected,
bevelled edges restored

Updated

13 years ago
No longer blocks: 304925
Depends on: 304925
Whiteboard: [ui polish]
Why not have a small black downward pointing arrow in the lower right corner to indicate that something will pop up?
QA Contact: nobody → rss.preview
The new theme has an icon for this (see URL), so we just need someone to write the code that will get it to show up when there are multiple feeds; we already set the tooltip depending on the number of feeds (see bug 304925) so there's a check for that case that already exists ...
Keywords: polish
Whiteboard: [ui polish] → [Fx2 theme change]
Target Milestone: --- → Firefox 2

Comment 18

12 years ago
(In reply to comment #17)

> The new theme has an icon for this (see URL), 

If you're running BonEcho, load:

chrome://browser/skin/livemark-item.png

And you'll see the graphic with all the livemark images in it. The easiest solution here is to change the -moz-region on the livemark icon to shift it over 18px to the right when there are multiple feeds, which will give us the icon with the dropmark (that's what already happens in my local XP build, but not in my local Mac build - are we sure this is still a problem on Winstripe?). 
(In reply to comment #17)
> we already set the tooltip depending on the number of feeds (see bug 304925)

Only during the time between the feedview backout and the feed preview landing: now it's bug 340064 where you wanted new strings and didn't tell me not to retarget instead of doing late-l10n.

(In reply to comment #18)
> (that's what already happens in my local XP build, but not in my
> local Mac build - are we sure this is still a problem on Winstripe?). 

If you're getting it in Windows, then you either have an unlanded patch in your tree, or you have an unsubmitted patch you should be putting in this bug. I don't see a dropmarker for multiple feeds in this morning's bone cho nightly.
And in fact this is currently not-simple: the FeedHandler.harvestFeeds() function that decides which feeds to show, and which to hide because it thinks "Foo in Atom" "Foo in RSS 2.0" and "Foo in RSS 1.0" is two too many, doesn't run until the icon is clicked.

I don't think that running it as feeds are discovered would make it flickery, unless I'm missing a case where adding a feed to 2 or more that passed harvestFeeds() would result in only one passing, but it does mean rewriting things so that unwanted feeds are just hidden, not removed, and it needs to be quick about it, since it would be slowing down pageload for any page with feeds, instead of only slowing down reaction to subscription clicks. 
Blocks: 340064

Comment 21

12 years ago
too late for Fx2. reopen or refile when Fx3 features appear, if this is still a problem.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Would it be possible to get this into one of the upcoming versions like 3.7?

Comment 23

9 years ago
I don't think it's important to indicate that the behavior after clicking will be different.  Users see these icons a lot more often than they click on them.  Having different icons depending on whether there are multiple feeds would mostly add visual noise.

Instead, we should push for sites to give users fewer pointless feed choices, e.g. https://bugzilla.wikimedia.org/show_bug.cgi?id=18801.
That would be a solution in a world where more than one feed is *always* pointless choice of formats. In the actual world, it's not.

Comment 25

9 years ago
It's *usually* either a pointless choice of formats or a misplaced choice of information.  I contend that this makes it less useful for the browser to indicate whether there are multiple feeds.

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago9 years ago
Component: RSS Discovery and Preview → Theme
QA Contact: rss.preview → theme
Resolution: --- → WORKSFORME

Comment 26

9 years ago
Why is this bug marked as WFM?  Was it fixed in the Windows theme (but not the Mac theme)?
I misread what this bug was about.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Target Milestone: Firefox 2 → ---
You need to log in before you can comment on or make changes to this bug.