If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

wrong translation in the URL of links for ampersand

VERIFIED INVALID

Status

SeaMonkey
Composer
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: mwbug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

I want to define the URL
http://some.server/cgi-bin/doc_view.cgi?doc_name=someDocument&edition=ALL
as a link in composer. Automatically the '&' is translated to & .
This makes the link unusable and the page is not found
I corrected the link directly in <html> source view (from &amp; back to &), but
on switching to another view or on save it is changed back to &amp; .

Reproducible: Always

Steps to Reproduce:
1.insert link
2.add http://some.server/cgi-bin/doc_view.cgi?doc_name=someDocument&edition=ALL
as link
3.save

Actual Results:  
the link in the html document is invalid (described in Details).

Expected Results:  
The ampersand should not be changed to &amp; in URLs.
ampersands must be escaped in HTML. the link should still work fine, though.
what is the url that mozilla requested, that caused the problem?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
You are right, the &amp; in links is accepted by browsers without problems. I
never did this in links in handcoded html, though and was therefore confused :-)
So really this is not a bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.