context menu appears on right click down instead of release

RESOLVED INCOMPLETE

Status

SeaMonkey
UI Design
--
minor
RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: ChrisX, Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050815 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050815 SeaMonkey/1.0a

When right-clicking, Mozilla 1.8 used to display the contextual menu only after
releasing the button. Seamonkey 1.0a displays it right after clicking, but only
in all tabs right next to the first tab.

Reproducible: Always

Steps to Reproduce:
1.get a Mac
2.open a second/third etc. tab
3.right click in that second tab
Actual Results:  
displays contextual menu right after clicking

Expected Results:  
should display contextual menu only after releasing

This makes rocker gestures (righ-left combinations for backward/forweward
browsing) impossible. This is a nuissance because I automated this feature and
use it (in vain) all the time. This is a regression from Moz. 1.8b2.
(Reporter)

Updated

12 years ago
Component: General → XP Apps: GUI Features

Comment 1

12 years ago
Hmm, I don't see any difference with Moz 1.7.7 and the latest SeaMonkey nightly
(Mac OS 10.3.9). Might be missing something, but I don't understand the issue.
Can you explain in more detail what the issue is?
(Reporter)

Comment 2

12 years ago
Well, the issue is that the mouse "rocker gestures" (left-right-click
combinations for browsing the history back & forward) don't work correctly
anymore on Seamonkey 1.0a, while they work on Mozilla 1.8b2. I have both
browsers on my system right now. Both browsers use the very same preferences in
my library, which is also the place where the mouse gestures plugin is
installed. If I start Mozilla, the rocker gestures work. If I start Seamonky
they don't work. That means, there must be something different in Seamonkey. It
all depends on how the browser handles right clicks. If I get a contextual menu
already upon holding down the right button, the menu interferes with the gesture
and practically cancels it. The menu is not supposed to show up at all when
performing a rocker gesture. It is a bit difficult to explain to someone who
isn't used to this way of navigating. It's like someone hits Escape, expects the
page to stop loading, and gets a contextual menu or something else instead. It
is irritating.
(Reporter)

Comment 3

12 years ago
I found a workaround for the problem: If you set dom.event.contextmenu.enabled
to "true", everything is back to normal, i.e. the contextual menu does not
interfere with mouse rocker gestures anymore. This is *not* a good solution,
though, and the bug is not fixed: Every time a silly javascript blocks my
contextual menu I still have to set the string to "false" temporarily or click
through the UI for javascript prefs. All I can say is that this bug was not
present in the last Mozilla 1.8b2 built I used (built on March 5, 2005), but
must have been introduced somewhere inbetween that and the first SeaMonkey built
I used (built on August 15, 2005).
(Reporter)

Updated

12 years ago
Severity: normal → minor
Summary: context menu on right click down instead of release → context menu appears on right click down instead of release
Version: unspecified → Trunk

Comment 4

12 years ago
There's a bug filed somewhere that it's impossible to distinguish between extensions (such as rocker gestures) and web pages trying to disable your context menu. However, as far as I know, this bug predates 1.8b2, and I don't know of any changes in context menu behaviour between then and now.
(Reporter)

Comment 5

12 years ago
This bug was completely resolved in SeaMonkey 1.0b, and re-introduced in SeaMonkey 1.5a, and there even without the chance to workaround with the JavaScript options.
(Reporter)

Comment 6

12 years ago
Now again present but with chance to workaround in build: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060116 SeaMonkey/1.5a

I really don't get it... Somebody must be switching on and off some features which have this side-effect.
Can you reproduce with SeaMonkey v1.1.9 ?
Can you reproduce with SeaMonkey v2.0a1pre ?
Keywords: regression

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
No reply to comment #7 after 3 months.

I've always thought that the existence of two ways to trigger a menu ("click and hold - drag - release" or "click and release - mouseover - click left" was intended (and indeed, depending on circumstances, I find one or the other more useful).

Robert, Neil, what do you think? Should this bug be resolved WONTFIX? (I do see menus, including context menus, open on mousedown, and I like it that way.)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008080500 SeaMonkey/2.0a1pre

Comment 9

9 years ago
given that it's been reported as on-and-off and no comments about being reproduced for a longer time, I take this as an incomplete report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Comment 10

9 years ago
Actually, I also think that the correct behaviour for mac is the right-click down behaviour.
You need to log in before you can comment on or make changes to this bug.