Last Comment Bug 304968 - nodes of type xsd:decimal in ]-1;1[ interval are invalid
: nodes of type xsd:decimal in ]-1;1[ interval are invalid
Status: RESOLVED FIXED
: fixed1.8, testcase
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Doron Rosenberg (IBM)
: Stephen Pride
Mentors:
http://www.mozilla.org/projects/xforms/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 07:19 PDT by Allan Beaufour
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Testcase (1.51 KB, application/xhtml+xml)
2005-08-17 07:20 PDT, Allan Beaufour
no flags Details
patch (1.37 KB, patch)
2005-10-11 14:47 PDT, Doron Rosenberg (IBM)
peterv: review+
peterv: superreview+
mozilla: approval1.8rc1+
Details | Diff | Splinter Review

Description Allan Beaufour 2005-08-17 07:19:25 PDT
 
Comment 1 Allan Beaufour 2005-08-17 07:20:09 PDT
Created attachment 192936 [details]
Testcase
Comment 2 Doron Rosenberg (IBM) 2005-08-17 07:47:12 PDT
known issue, its fixed in my tree already :)
Comment 3 Allan Beaufour 2005-08-17 07:55:01 PDT
(In reply to comment #2)
> known issue, its fixed in my tree already :)

Ah, then it's not a bug I guess. My bad for not checking your tree first ;-)
Comment 4 Doron Rosenberg (IBM) 2005-10-11 14:47:43 PDT
Created attachment 199208 [details] [diff] [review]
patch

Since this is annoying, putting a patch here.

basically, someone contributed a patch that added leading 0 stripping, but the
code doesn't take 000.23 into consideration, and returned .23, which is
invalid. 

Therefore, if the decimal part is all zeros, we set it to "0".
Comment 5 Doron Rosenberg (IBM) 2005-10-14 09:47:58 PDT
checked into trunk
Comment 6 Mike Kaply [:mkaply] 2005-10-14 09:51:55 PDT
Comment on attachment 199208 [details] [diff] [review]
patch

a=mkaply
Comment 7 Doron Rosenberg (IBM) 2005-10-14 12:49:42 PDT
checked into branch

Note You need to log in before you can comment on or make changes to this bug.