Firefox crashes when downloading a file or click "save as..." under gtk 2.8

RESOLVED INVALID

Status

()

Core
Widget: Gtk
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Thorsten 'nightrat' Fritz, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050817 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050817 Firefox/1.6a1

Firefox crashes when you choose "save as...". Choose a location to save the file
and press "ok". Firefox crashes completly.

I tested with the build yesterady and today. With an old and with a new profile.
Same result.

Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 1

12 years ago
Get a talkback id for the crash: http://kb.mozillazine.org/Talkback
(Reporter)

Comment 2

12 years ago
I can't get a talkback id because talkback isn't started. I think this has
something to do with bug 305046.
WFM on WinXP.
Build LastVersion=1.6a1_2005081802/1.9a1_2005081802
(Reporter)

Comment 4

12 years ago
I tried with todays build Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1)
Gecko/20050818 Firefox/1.6a1 BuildID = "2005081805".
Same result. Firefox crashes. Talkback ID=TB8490123E

Updated

12 years ago
Assignee: nobody → blizzard
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Are you running Gtk 2.8?
(Reporter)

Comment 6

12 years ago
Yes, i am running GTK 2.8 on Ubuntu Breezy with Gnome 2.11.90.
Then that's the problem; gtk 2.8 isn't officially supported yet, though it
sounds like this is a bug for caillon, in the platform native file dialog.
Nominating for blocking; 2.8 isn't shipping with any full distros yet, but it's
popping up in unstable repositories, and will probably be part of all future
distros.  We don't really want 1.5 to have problems on those.
Flags: blocking1.8b4?
Summary: Firefox crashes when downloading a file or click "save as..." → Firefox crashes when downloading a file or click "save as..." under gtk 2.8
On second thought, this looks like a bug that was fixed in cairo -- rendering a
run of glyphs with no width or height (like "   " caused it to crash).  What
version of cairo is included with breezy?
(Reporter)

Comment 10

12 years ago
Breezy uses Cairo 0.9.2.

Comment 11

12 years ago
Vlad,

Can you look into a workaround to GTK 2.8 issues?

Mike
Flags: blocking1.8b4? → blocking1.8b4+

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Caused by an old version of cairo/gtk2.8; there don't seem to be any problems
with the released versions (cairo 1.0.0, gtk 2.8.1).  -> invalid
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

12 years ago
Flags: blocking1.8b4+
You need to log in before you can comment on or make changes to this bug.