Can't type automatic proxy configuration url in connection settings

VERIFIED DUPLICATE of bug 302486

Status

()

Firefox
Preferences
VERIFIED DUPLICATE of bug 302486
13 years ago
13 years ago

People

(Reporter: Stuart Dunkeld, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050816 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050816 Firefox/1.0+

When any character is typed into the automatic proxy configuration url textbox,
the textbox tries to help by autofilling the http:// protocol, except it gets it
wrong, and the resulting mess can't be deleted with backspace. Reproduced on
XP/WS2003 on nightly builds as well as Mac OSX.

Reproducible: Always

Steps to Reproduce:
1. Open connection settings in preferences
2. Select "automatic proxy configuration url"
3. Type (for example) the letter "s" in the textbox 


Actual Results:  
The textbox contains http://s/ and backspace has no effect on the value. The
string can be selected and deleted or pasted over, although the autofill happens
every time a charatcer is typed in the empty textbox.

Expected Results:  
It's OK to autofill the http: I suppose, although it's not ideal. Is http the
only supported protocol for .pac files? How about prefixing the url with http
internally if no protocol is specified but letting the UI display the partial
address the user entered?

Workaround - paste in the URL of the .pac file.

*** This bug has been marked as a duplicate of 302486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Can't type automatic proxy configuration url in connection settings → Can't type automatic proxy configuration url in connection settings
v. dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.