invalid behaviour of getAnonymousNodes() and getAnonymousElementByAttribute()

RESOLVED DUPLICATE of bug 305065

Status

()

Core
XBL
RESOLVED DUPLICATE of bug 305065
12 years ago
12 years ago

People

(Reporter: surkov, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b3) Gecko/20050719 SeaMonkey/1.0a

I have a binding with content:

<children includes="caption">
	<xul:description value="Binding" anonid="desc"/>
</children>
<children/>

I have a bound element:

<testbox>
	<button label="helo"/>
</testbox>

When I call in constructor the following methods, I get: 

document.getAnonymousNodes(this)[0] returns button element
document.getAnonymousElementByAttribute(this, 'anonid', 'desc') returns null

I expect to get description element.

Reproducible: Always

Comment 1

12 years ago
Duplicate of bug 305065

*** This bug has been marked as a duplicate of 305065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.