Focus change via JavaScript loses form data

VERIFIED INCOMPLETE

Status

()

--
critical
VERIFIED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: moch_isnaini, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 06/29)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

please try in javascript  form.id_name.focus();  --> action will be refresh form
and lost all entry.

Reproducible: Always

Steps to Reproduce:
1.make form / document with name form and editbox with name id_name.
2.every call form.id_name.focus() --> will refresh form.
3.

Actual Results:  
Everything user entry will lost because firefox use refresh.

Expected Results:  
Will -- move focus, without refresh.
Please attach a simple testcase that demonstrates this problem.

Updated

13 years ago
Keywords: dataloss
Summary: Javascript → Focus change via JavaScript loses form data
(Reporter)

Comment 2

13 years ago
20050822 -- I found that error is not on focus(), but every keypress always 
submit ( then refresh ).
Can Firefox only submit it another function in javascript hook event ?.

Comment 3

12 years ago
Reporter, are you still seeing this problem with the latest release of Firefox when using a clean profile?

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME - 06/29
Muhammad, please attach a testcase that exhibits the behavior you described and make sure that this doesn't happen using Firefox 2.0.0.6 or later with a clean profile (link in comment 3). Reopen this bug when you do so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.