Gmail compose, keyboard navigation broken and focus removed

VERIFIED DUPLICATE of bug 300453

Status

()

--
major
VERIFIED DUPLICATE of bug 300453
13 years ago
13 years ago

People

(Reporter: Peter6, Assigned: jst)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050818 
Firefox/1.0+ ID:2005081802

this initially regressed with the first checkin of bug 296639
was partially resolved by the patch for bug 296639 that fixed bug 302885

repro:
1. open FF
2. open Gmail
3. presss "Compose Mail"
4. Set editing to "Rich Formatting"
-4a. place the cursor anywhere except in the "text edit field"
-4b. try to tab to the "text edit field" , it won't work <-1st part of bug
-----(isn't that what bug 302885 is about, needs to be reopened ?)

5. Place the cursor in the "text edit field"
6. Type some text and press the button "textcolor" or "background-color"
7. this removes the cursor from the text editing field  <-2nd part of bug
-----(only works for underline/bold/italic)

this all worked before the first checkin of bug 296639


probably doesn't work on trunk either.
(Reporter)

Updated

13 years ago
Summary: Gmail compose keyboard navigation broken → Gmail compose, keyboard navigation broken and focus removed
Flags: blocking1.8b4?
Confirming on trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1
Blocks: 296639

Updated

13 years ago
Assignee: nobody → jst
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Comment 2

13 years ago
This has nothing to do with bug 296639 (other than that bug breaking editable
documents completely, but that was fixed in bug 302885). The focus problems here
were caused by the fix for bug 299424.

When tabbing into the edit area on a gmail compose page gmail uses a mostly
hidden input element in the document containing the ediatable iframe, this input
element is in the right place in the tab order and this element is there only to
properly move focus into the editable iframe when you tab into the input. When
this input gets focus, it fires off a timeout that through several layers of
code ends up calling focus() on the ediable iframe window. Due to the change in
the default value for the pref "dom.disable_window_flip", the focus() call does
nothing, and focus is seemingly lost in the gmail page. Same mechanism is used
when you use the "toolbar" above the ediatable document.
No longer blocks: 296639
This is basically the same as bug 304746 and bug 300453.
Depends on: 300453
(Assignee)

Comment 4

13 years ago
Yeah, duping, even.

*** This bug has been marked as a duplicate of 300453 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
No longer depends on: 300453

Updated

13 years ago
Flags: blocking1.8b4+
You need to log in before you can comment on or make changes to this bug.