browser.xul.error_pages.enabled should be removed

RESOLVED INVALID

Status

()

Core
Document Navigation
--
enhancement
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Andreas Morawietz, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818 Firefox/1.6a1

browser.xul.error_pages.enabled should be set to true by default and can be
removed. 

I think, nobody needs the old popup-windows with error-messages, because they
contain less information about the error and how it can be solved.
error pages are much better!

Additional, I think that firefox could be faster, if there are fewer options -
because firefox must load fewer options. Am I right? 


Reproducible: Always
browser.xul.error_pages.enabled is set to true by default.

-> WFM?
He was talking about removing the whole pref.
I don't think the browser would become faster, but I think I agree the pref can
be removed.
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> He was talking about removing the whole pref.
> I don't think the browser would become faster, but I think I agree the pref can
> be removed.

Thanks. Ok, with removing this one pref, firefox wouldn't become faster.
But I think, if firefox had fewer prefs, it could be faster. It's only a thought...

Comment 4

13 years ago
The cost of one pref is very cheap, so that shouldn't really matter. But i think
there are people that don't want error pages for some reasons (for example
certain embedders).
Assignee: nobody → adamlock
Component: Preferences → Embedding: Docshell
Product: Firefox → Core
QA Contact: preferences → adamlock
Version: unspecified → Trunk

Comment 5

13 years ago
I don't want error pages.

Comment 6

13 years ago
some of us don't want xul. i don't want error pages.
(Reporter)

Comment 7

13 years ago
some people want to use these popup-windows
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.