Closed Bug 305151 Opened 16 years ago Closed 15 years ago

make freebl a shared library on all NSS platforms

Categories

(NSS :: Libraries, enhancement, P1)

3.10
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 303508

People

(Reporter: nelson, Assigned: saul.edwards.bugs)

References

Details

As part of the SSL performance work for NSS 3.11, libSSL wants to be able to
call freebl functions without going through PKCS11, on all paltforms.  To that 
end, and to avoid having multiple copies of freebl code linked into NSS, 
freebl should be a shared lib on all platforms.
This is a prerequisite for the "bypass" in bug 305147.  
Priority: -- → P1
Target Milestone: --- → 3.11
Saul, This bug is P1 for NSS 3.11.  Is this work done now?  
Is it ready to be marked fixed?
If so, to which bug were its patches attached?
I think the work is done in the sense that we are building shared libs on all
platforms on the tip now. There may be some changes remaining to be done in
loader, but all of them are being discussed in bug 303508 .
We should probably close this bug as duplicate.
I agree wtih Julien. Closing as duplicate of bug 303508.

*** This bug has been marked as a duplicate of 303508 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.