Crash going back while loading an image [@ ImageListener::OnStopRequest]

RESOLVED FIXED

Status

()

Core
ImageLib
--
critical
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Tracking

({crash, regression, verified1.8})

Trunk
x86
Windows 2000
crash, regression, verified1.8
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
To reproduce this fetch a current nightly build, then do this:

1. Go to http://uc.relog.ch/bygw/
2. Click on any picture
3. Click the back button while the image is still loading

Result:
Crash

Stacktrace:
ImageListener::OnStopRequest(ImageListener * const 0x00000000, nsIRequest *
0x03a68b74, nsISupports * 0x00000000, unsigned int 2152398850) line 233 + 11 bytes
nsDocumentOpenInfo::OnStopRequest(nsDocumentOpenInfo * const 0x03b5ef38,
nsIRequest * 0x03a68b74, nsISupports * 0x00000000, unsigned int 2152398850) line 390
nsStreamListenerTee::OnStopRequest(nsStreamListenerTee * const 0x03a68b74,
nsIRequest * 0x03a68b7c, nsISupports * 0x012fe982, unsigned int 63985264) line
65 + 21 bytes
XPCOM_CORE! @ILT+2225(?assign_with_AddRef@nsCOMPtr_base@@QAEXPAVnsISupports@@@Z)
address 0x100018b6
nsInputStreamPump::OnStateStop(nsInputStreamPump * const 0x00000000) line 507
nsInputStreamPump::OnInputStreamReady(nsInputStreamPump * const 0x03cd62dc,
nsIAsyncInputStream * 0x03a11478) line 344
nsInputStreamReadyEvent::EventHandler(PLEvent * 0x03d0a1a4) line 120
PL_HandleEvent(PLEvent * 0x03d0a1a4) line 689
PL_ProcessPendingEvents(PLEventQueue * 0x10033bc2) line 623 + 6 bytes
_md_EventReceiverProc(HWND__ * 0x01a3cca5, unsigned int 1, unsigned int 1244908,
long 27080919) line 1409
0012ffb0()

Almost certainly fallout from Bug 292503.

Updated

13 years ago
Severity: normal → critical

Comment 1

13 years ago
(In reply to comment #0)

> To reproduce this fetch a current nightly build, then do this:
> 
> 1. Go to http://uc.relog.ch/bygw/
> 2. Click on any picture
> 3. Click the back button while the image is still loading
> 
> Result:
> Crash

Sorry Frank. I cant reproduce that. All pictures loading correctly and the
back-buttom works fine(eaven while loading the pictures).

Testet with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050819 SeaMonkey/1.0a Build 2005081907

Comment 2

13 years ago
I can confirm this with CREATURE-Builds 2005081906 and 2005081909; TB8529643H
(Assignee)

Comment 3

13 years ago
BTW: Another way to reproduce this is opening a picture in a new tab and closing
that tab during load.
To prevent any more debugging on this ;), the problem is imgDoc->mImageContent
being null (probably because ::Destroy is called async which sets mImageContent
to null).
(Assignee)

Comment 4

13 years ago
Created attachment 193207 [details] [diff] [review]
Patch

Also fixed the review comments from the other bug
Assignee: stuart → bugzilla
Status: NEW → ASSIGNED
Attachment #193207 - Flags: review?(cbiesinger)
Comment on attachment 193207 [details] [diff] [review]
Patch

I'd add a comment describing why mImageContent can be null (namely, because the
document is already destroyed at this point)
Attachment #193207 - Flags: review?(cbiesinger) → review+
(Assignee)

Updated

13 years ago
Attachment #193207 - Flags: superreview?(jst)
Summary: Crash going back while loading a image [@ ImageListener::OnStopRequest → Crash going back while loading an image [@ ImageListener::OnStopRequest

Comment 6

13 years ago
*** Bug 305299 has been marked as a duplicate of this bug. ***
Comment on attachment 193207 [details] [diff] [review]
Patch

sr=jst
Attachment #193207 - Flags: superreview?(jst) → superreview+
Comment on attachment 193207 [details] [diff] [review]
Patch

Regression fix for another patch I'd like to land on branch.
Attachment #193207 - Flags: approval1.8b4?

Updated

13 years ago
Flags: blocking1.8b4+

Updated

13 years ago
Attachment #193207 - Flags: approval1.8b4? → approval1.8b4+
Landed along with bug 292503 on branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Verified on Deer Park branch with: Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8b4) Gecko/20050901 Firefox/1.0+
Keywords: fixed1.8 → verified1.8

Updated

13 years ago
Summary: Crash going back while loading an image [@ ImageListener::OnStopRequest → Crash going back while loading an image [@ ImageListener::OnStopRequest]
Crash Signature: [@ ImageListener::OnStopRequest]
You need to log in before you can comment on or make changes to this bug.