Up min/max version of XForms extension

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
12 years ago
8 months ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: Allan Beaufour)

Tracking

({fixed1.8})

Trunk
x86
All
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
 
(Reporter)

Comment 1

12 years ago
Created attachment 193194 [details] [diff] [review]
1.4 is 1.5 beta, 1.6a1 is trunk
Attachment #193194 - Flags: review?(aaronr)

Comment 2

12 years ago
This bug addresses the fact that the nightly xforms.xpi no longer installs on a
nightly trunk build.

Comment 3

12 years ago
Comment on attachment 193194 [details] [diff] [review]
1.4 is 1.5 beta, 1.6a1 is trunk

well, this gets the xforms.xpi to install, but now the browser hangs trying to
load an XForm.	Guess we'll look at that in a seperate bug once I get a chance
to debug it more.
Attachment #193194 - Flags: review?(aaronr) → review+

Comment 4

12 years ago
(In reply to comment #3)
> (From update of attachment 193194 [details] [diff] [review] [edit])
> well, this gets the xforms.xpi to install, but now the browser hangs trying to
> load an XForm.	Guess we'll look at that in a seperate bug once I get a chance
> to debug it more.
> 

The hang trying to load a form is caused by a bug introduced in XPath.  The
patch to bug 305326 will fix the hang.
Comment on attachment 193194 [details] [diff] [review]
1.4 is 1.5 beta, 1.6a1 is trunk

I think we should have minVersion 1.4 and maxVersion 1.5 for branch, and 1.6a1
would be trunk only. Some interfaces may change so that the extension will not
stay binary compatible in both trunk and branch.
(Assignee)

Comment 6

12 years ago
(In reply to comment #5)
> (From update of attachment 193194 [details] [diff] [review] [edit])
> I think we should have minVersion 1.4 and maxVersion 1.5 for branch, and 1.6a1
> would be trunk only. Some interfaces may change so that the extension will not
> stay binary compatible in both trunk and branch.

Good idea. We should get a "pre-release" ready for 1.5 release, but then
continue working on trunk, occasionally trying to see/getting it to work on
branch and then manual create a new version?
(Assignee)

Comment 7

12 years ago
Created attachment 195405 [details] [diff] [review]
Patch for branch
Attachment #195405 - Flags: review?(aaronr)
(Assignee)

Updated

12 years ago
Attachment #195405 - Flags: review?(smaug)

Comment 8

12 years ago
Comment on attachment 195405 [details] [diff] [review]
Patch for branch

This is fine with me, but we need to verify with Mozilla.org whether we should
possibly have 1.5+ as max version instead of 1.5.  So what we need to know is
whether they are going to bump the version when they do 1.5.1, etc. security
releases.

Doron, please check this answer with Mozilla.org and get this patch checked in
to branch ASAP.  Thanks.
Attachment #195405 - Flags: review?(smaug)
Attachment #195405 - Flags: review?(doronr)
Attachment #195405 - Flags: review?(aaronr)
Attachment #195405 - Flags: review+
(Assignee)

Comment 9

12 years ago
http://developer.mozilla.org/devnews/index.php/2005/08/16/extension-version-changes/
(Reporter)

Comment 10

12 years ago
Comment on attachment 195405 [details] [diff] [review]
Patch for branch

Branch is closed right now.

What we should do is have an update.rdf somewhere on mozilla.org and reference
it in the install.rdf.	We can then do version bumping remotely.
Attachment #195405 - Flags: review?(doronr) → review+
(Assignee)

Comment 11

12 years ago
(In reply to comment #10)
> (From update of attachment 195405 [details] [diff] [review] [edit])
> Branch is closed right now.
> 
> What we should do is have an update.rdf somewhere on mozilla.org and reference
> it in the install.rdf.	We can then do version bumping remotely.
> 

That assumes that you can actually install the xpi. You cannot, because it is
incompatible. This needs to go in .... now.

Comment 12

12 years ago
*** Bug 307872 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #195405 - Flags: approval1.8b5?

Updated

12 years ago
Attachment #195405 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Comment 13

12 years ago
Created attachment 195860 [details] [diff] [review]
Patch for trunk

Set to 1.6a1 for trunk
Assignee: doronr → allan
Attachment #193194 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #195860 - Flags: review?(aaronr)
(Assignee)

Comment 14

12 years ago
(In reply to comment #7)
> Created an attachment (id=195405) [edit]
> Patch for branch

I checked it in to branch with 1.4 -> 1.5, so the nightly builds will work
immediately.
(Assignee)

Updated

12 years ago
Keywords: fixed1.8

Updated

12 years ago
Attachment #195860 - Flags: review?(aaronr) → review+
(Assignee)

Updated

12 years ago
Attachment #195860 - Flags: review?(smaug)
Attachment #195860 - Flags: review?(smaug) → review+
(Assignee)

Comment 15

12 years ago
Checked in to trunk.

Bug 298431 actually fixes this forever. It is reviewed an approved, but is
waiting for build script changes. Doron promised to get hold of Chase.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.