crash if clicking on an image and closing that new window [@ ImageListener::OnStopRequest ]

VERIFIED DUPLICATE of bug 305215

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 305215
13 years ago
7 years ago

People

(Reporter: Andreas Morawietz, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050819 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050819 Firefox/1.6a1

Clicked on third image in second row on 
http://www.partysaarfari.de/index.php?page=digitalarts
A new window opens.
If I close that window, firefox crashs.

-->  TB8545417G



Reproducible: Always

Updated

13 years ago
Keywords: crash
(Reporter)

Comment 1

13 years ago
This crash only happens in newest trunk - the branch closes that window without
a crash.
stack

Stack Signature	 ImageListener::OnStopRequest 14a41d78
Product ID	FirefoxTrunk
Build ID	2005081922
Trigger Time	2005-08-20 02:57:10.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (001b9fb8)
URL visited	http://www.partysaarfari.de/index.php?page=digitalarts
User Comments	Clicked on third image in second row. A new window opens. If I
close that window, firefox crashs. WHY???
Since Last Crash	30 sec
Total Uptime	30 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/html/document/src/nsImageDocument.cpp,
line 234
Stack Trace 	
ImageListener::OnStopRequest 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/html/document/src/nsImageDocument.cpp,
line 234]
nsDocumentOpenInfo::OnStopRequest 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/uriloader/base/nsURILoader.cpp,
line 390]
nsStreamListenerTee::OnStopRequest 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsStreamListenerTee.cpp,
line 65]
nsInputStreamPump::OnStateStop 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 507]
Summary: crash if clicking on an image and closing that new window → crash if clicking on an image and closing that new window [@ ImageListener::OnStopRequest ]
Summary: crash if clicking on an image and closing that new window [@ ImageListener::OnStopRequest ] → crash if clicking on an image and closing that new window [@ ImageListener::OnStopRequest ]

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 305215 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Crash Signature: [@ ImageListener::OnStopRequest ]
You need to log in before you can comment on or make changes to this bug.