{inc}Problem changing font size in page with css specifying float property

RESOLVED FIXED

Status

()

Core
Layout: Floats
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: paolopantaleo, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

The page reported in the URL make Firefox act in a strange way:
When the page is loaded it it displayed as expected.
But when i try to change font size for it (with CTRL + mouse wheel) the layout
get messed, if i reload the page it is display correctly.
If i chabge the firefox window sisze the pge is displated correctly.
I observed this problem on :
* FIrefox 1.0.4 on Debian
* Firefox 1.0.6 on WIndows
The same page seems to work properluy with konqueror.

The page is:
http://mypic.altervista.org/fire_bug/index.shtml

Reproducible: Always
Created attachment 193275 [details]
testcase comment #0

Updated

13 years ago
Component: General → Layout
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050820
Firefox/1.0+ ID:2005082003
I see this rendering issue too.

Comment 3

13 years ago
Created attachment 193304 [details]
more reduced testcase

based on first testcase, lots of stuff removed. Doesn't look like 1st on load,
but after resizing.

Comment 4

13 years ago
Also seen in 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050819 SeaMonkey/1.0a
Summary: Problem cahnging font size in page with css specifying float property → Problem changing font size in page with css specifying float property
Created attachment 193307 [details]
Even more reduced testcase

Showing that only one floating div is required.
Notice bug 284019 which has a better summary but doesn't have a testcase and is
still unconfirmed.

This is also very similar to bug 201215 (except the "percentage-width" part
doesn't seem to be necessary in this case).
Summary: Problem changing font size in page with css specifying float property → {inc}Problem changing font size in page with css specifying float property
Whiteboard: [reflow-refactor]
Version: 1.0 Branch → 1.7 Branch

Comment 8

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008
Firefox/1.6a1
Confirmed using current Firefox Trunk Build.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Floats
Ever confirmed: true
Version: 1.7 Branch → Trunk

Comment 9

12 years ago
*** Bug 284019 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
Created attachment 213391 [details]
testcase using div and display:table rather than actual table

This is also reproducible using a div with display:table applied, rather than an actual table.

Oh, and I can reproduce this on both Firefox 1.5 and today's Camino nightly on Mac OS X (10.4.5).

Comment 11

11 years ago
replacing http://mypic.altervista.org/fire_bug/index.shtml as it gives a 404

Bug seen in dupe Bug 284019
{inc}Right float inside table gets scrunched up when text size is changed
http://en.wikipedia.org/wiki/WP:RFAR 

Bug 300193 duped to Bug 25888 inlines wrapping around floats only check top pixel of line for overlap (negative top margin)
http://en.wikipedia.org/wiki/Hurricane_Dennis

some other wikipedia links:
http://en.wikipedia.org/wiki/World_Bank_Group
http://en.wikipedia.org/wiki/International_Monetary_Fund

Comment 12

11 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061104 SeaMonkey/1.1b

the testcases are seen identical (not fixed) on Seamonkey and Firefox2

replacing URL again as it doesn't show the resizing problem this bug is about.
From a dupe I got the impression this bug was about the bug seen on en.wikipedia pages, but that seems to be bug 25888

the en.wikipedia URLs are displaying fine on Firefox2, but are shown broken on Seamonkey:
http://en.wikipedia.org/w/index.php?title=Oahu&oldid=58021284
http://en.wikipedia.org/wiki/Orangequat
http://en.wikipedia.org/wiki/Image:Layout_engine_usage_share.svg

http://en.wikipedia.org/wiki/International_Monetary_Fund

valid XHTML1.0: http://validator.w3.org/check?uri=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FInternational_Monetary_Fund
Errors in CSS: http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FInternational_Monetary_Fund&usermedium=all





Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
Weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(Resizing text on website forces a reflow and the layout gets all screwed)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(Resizing text on website maintains page layout as expected)

-->RESOLVED FIXED 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 300030
Resolution: --- → FIXED
Need regression test.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.