page is downloaded instead of displayed when cookies are being blocked

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: pjs38, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050427 Camino/0.8.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050427 Camino/0.8.4

self-explanatory

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
WFM, 2005081904 (v0.9a2+) branch, 10.3.9.

Please check this in 0.9a2 or a recent nightly build.
Component: Accessibility → General
(Reporter)

Comment 2

13 years ago
this happens in .9a2 as well.
WFM in 0.9a2 also.  Are you accepting cookies?
(Reporter)

Comment 4

13 years ago
you asked if i am accepting cookies:

i dont even get to the cookie dialogue window--the page just starts to download.  
You're either not accepting cookies from any site or at some point you've
blocked cookies from www.redenvelope.com.  Go into the Privacy prefs and make
sure you're accepting cookies *and* check the Exceptions list to make sure you
haven't set any redenvelope.com domains to deny to fix this.

A recent DeerPark nightly behaves the same way and tries to download the page
when you aren't accepting cookies.

Safari 1.3 just stalls with a blank white page trying to load the page when you
don't accept cookies; iCab actually loads the page.

Not sure what the proper behavior is in this case, although from the user
perspective it's certainly "display the page".  Also not sure if this goes in
Networking:Cookies or Networking:HTTP; apologies.  
Assignee: pinkerton → darin
Status: UNCONFIRMED → NEW
Component: General → Networking: Cookies
Ever confirmed: true
Product: Camino → Core
QA Contact: networking.cookies
Version: unspecified → Trunk
Actually, if you wait long enough, Safari ends up displaying the set-cookie
headers and then the raw gzip-encoded page content.

(Also tweaking the summary since I forgot when moving the bug....)
Summary: page downloads rather than loading in the browser window → page is downloaded instead of displayed when cookies are being blocked
0000044B  48 54 54 50 2f 31 2e 31  20 32 30 30 20 4f 4b 0d HTTP/1.1  200 OK.
0000045B  0a 53 65 72 76 65 72 3a  20 4e 65 74 73 63 61 70 .Server:  Netscap
0000046B  65 2d 45 6e 74 65 72 70  72 69 73 65 2f 36 2e 30 e-Enterp rise/6.0
0000047B  0d 0a 44 61 74 65 3a 20  53 75 6e 2c 20 32 31 20 ..Date:  Sun, 21 
0000048B  41 75 67 20 32 30 30 35  20 32 30 3a 33 32 3a 32 Aug 2005  20:32:2
0000049B  32 20 47 4d 54 0d 0a 43  6f 6e 74 65 6e 74 2d 74 2 GMT..C ontent-t
000004AB  79 70 65 3a 20 74 65 78  74 2f 68 74 6d 6c 0d 0d ype: tex t/html..
000004BB  0a 53 65 74 2d 63 6f 6f  6b 69 65 3a 20 54 4c 54 .Set-coo kie: TLT
000004CB  48 49 44 3d 41 44 39 36  30 37 35 38 31 32 38 32 HID=AD96 07581282

The 0d 0d 0a instead of 0d 0a after text/html seems to be the problem. This
looks like a server bug.
This worksforme in a current trunk build, even with cookies disabled.  Is this still an issue?
This also WFM in a Camino branch build (2005120304) with cookies disabled, although, for the record, it seems like the URL has changed.

Comment 10

12 years ago
-> default owner
Assignee: darin → nobody

Comment 11

11 years ago
-> wfm per comments
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.