Closed Bug 305368 Opened 19 years ago Closed 19 years ago

Pasting text into column 1 of Compose Window fails. Other columns OK.

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: mail, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050820 Firefox/1.6a1
Build Identifier: Thunderbird nightly build - version 1.6a1 (20050820)

Pasting text into the compose window does not work if the insertion point is at
the start of the line. Pasting works as expect if the cursor is at any other
position.

Reproducible: Always

Steps to Reproduce:
1. Open up a new compose window, type a few characters then Shift+Home and
Ctrl+C to copy
2. Try paste with cursor in column 1 of non-blank line: Type Home and Ctrl+V -->
Text should be pasted in, but nothing happens
3. Try paste with cursor in another column of a non-blank line: Type cursor
right and Ctrl+V --> Cursor start in col 2. Text gets pasted in as expected
4. Try paste with cursor at start of blank line: Type End, Enter and Ctrl+V
  --> Cursor in col 1 of blank line. Text gets pasted in.

Actual Results:  
Text only gets pasted in for two of the three above cases.

No text gets pasted if the insertion point is in column 1 in a non-blank line.
Pasting works as expected if the line is blank, or the insertion point is in any
other column of a non-blank line

Expected Results:  
Paste in text from clipboard in all three cases
I can't even open a compose window with the 0820 build (bug 305507).
Stephen Simmons, are you still encountering this bug with current nightlies?
I'm unable to reproduce with 1.6a1-0904 on Win2K.

If you no longer see the problem, please mark this bug: 
  Resolved | WorksForMe
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.