If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Software Update should mention tabs and pages will be lost on restart

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Recall, Unassigned)

Tracking

1.8.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050819 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050819 Firefox/1.0+ - Build ID: 2005081906

I think that the software update dialogue should mention that all tabs and
current open will be lost on a restart after a software update for the browser. 



Reproducible: Always

Steps to Reproduce:
1.Peform a browser update either by notification, or help check for updates
2. Download update if available.
3. Upon completion, update will ask you to restart your browser now or later,
with no mention of lost pages or tabs.

Actual Results:  
Lose all open tabs and current pages on restart

Expected Results:  
Something along the lines of. " Please note, all tabs and current open pages
will be lost on restart, do you wish to continue?"
WFM, although I tried it only in trunk. 

1. Firefox asks if I want to restart or update later. 
2. I get a close tab warning like usual.
3. I find the last visited addresses under Go and in my history.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
confirming

Comment 3

12 years ago
Is the following the problem? 

During the update process there is a checkbox that asks something like "Do you
want to use Firefox Start as your default start page?" 

If this is checked, then the current set of home page tabs is replaced by the
Firefox start.  

In my earlier Firefox updates this checkbox was checked by default -- so it's
easy to go through this page, leave it checked, and have the install process
wipe out your home/start tab settings.

In my last install (1.0.6), however, the checkbox was unchecked by default.
Don't know if this is just the installer 'reading' this as a pref set by my last
install, or a change in the installer config.

If this is the problem, maybe the best thing to do is to change the
install/update script to:

a) have this unckecked by default
b) if it is checked (selected by the user), make sure text is provided to warn
the user that this will delete any tabs currently used for the start page
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050821
Firefox/1.0+ ID:2005082110

I have browser.tabs.warnOnClose true but FF closes w/o a warning at app update
(In reply to comment #4)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050821
> Firefox/1.0+ ID:2005082110
> 
> I have browser.tabs.warnOnClose true but FF closes w/o a warning at app update
Scrap this remark, it worked again a few build later.
This is fixed in Firefox 2 by the newly integrated Session Restore feature.
Version: unspecified → 1.5.0.x Branch

Comment 7

11 years ago
Well... session restore is only a partial solution to the problem, since we're restoring from cache, which doesn't restore postdata and other no-cache pages properly.
Some wording changes in bug 346795 might render this bug INVALID now. Regarding Benjamin's concerns, in my experience, session restore has gotten things right more often than wrong ...
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
The warning dialog that is displayed isn't part of app update and is also displayed when restarting via the add-ons manager, etc. If the wording for the  warning dialog is not clear please file a bug against session restore.

resolving -> wfm
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.