XMLHttpRequest always sets "Cache-Control: no-cache" and "Pragma: no-cache"

RESOLVED DUPLICATE of bug 268844

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 268844
13 years ago
13 years ago

People

(Reporter: Dave Rolsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050730 Firefox/1.0.6 (Debian package 1.0.6-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050730 Firefox/1.0.6 (Debian package 1.0.6-2)

Even if I set an "If-Modified-Since" header these additional headers are always
set.  I thought this had been resolved since bug 268844 was closed, but
apparently it's still happening.

Note that this appears to be mostly a cosmetic problem.  At least with Apache,
it ignores the Cache-Control & Pragma headers when If-Modified-Since is given. 
But it still seems like a bug, and I wouldn't be surprised if other web server
acted differently.

Reproducible: Always
It was fixed on the trunk, so it will be fixed in 1.5: 1.0.6 is still off a
prior branch.

*** This bug has been marked as a duplicate of 268844 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.