Crash when closing window [@ nsPopupSetFrame::Destroy]

RESOLVED DUPLICATE of bug 326959

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 326959
12 years ago
4 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
<A
href="http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=+nsPopupSetFrame%3A%3ADestroy&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid">
45 crash incidents this month</a>
At least two of the crashes were when closing BugXULA extension while closing
the window. Please file under correct product and component.

This is what I got earlier:

Stack Signature	 nsPopupSetFrame::Destroy 3d22428a
Product ID	FirefoxTrunk
Build ID	2005082107
Trigger Time	2005-08-21 11:07:28.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	firefox.exe + (00276470)
URL visited	
User Comments	closed extension BugXULA
Since Last Crash	3657 sec
Total Uptime	3657 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsPopupSetFrame.cpp,
line 193
Stack Trace 	
nsPopupSetFrame::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsPopupSetFrame.cpp,
line 193]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsFrameList.cpp,
line 138]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1119]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1119]
ViewportFrame::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsViewportFrame.cpp,
line 67]
DocumentViewerImpl::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsDocumentViewer.cpp,
line 1440]
nsDocShell::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 3421]
nsXULWindow::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/xpfe/appshell/src/nsXULWindow.cpp,
line 511]
nsWebShellWindow::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp,
line 852]
nsWebShellWindow::HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp,
line 406]
nsWindow::DispatchEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1251]
nsWindow::DispatchStandardEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1291]
nsWindow::ProcessMessage 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 4285]
nsWindow::WindowProc 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1428]
USER32.dll + 0x3158f (0x77e4158f)
USER32.dll + 0x2c19d (0x77e3c19d)
USER32.dll + 0x2c1ca (0x77e3c1ca)
ntdll.dll + 0x11baf (0x77f91baf)
USER32.dll + 0x2c159 (0x77e3c159)
USER32.dll + 0x3158f (0x77e4158f)
USER32.dll + 0x2afa1 (0x77e3afa1)
USER32.dll + 0x2afc7 (0x77e3afc7)
nsWindow::WindowProc 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1435]
USER32.dll + 0x3158f (0x77e4158f)
USER32.dll + 0x31dc9 (0x77e41dc9)
USER32.dll + 0x31e7e (0x77e41e7e)
nsAppStartup::Run 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 146]
main 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 61]
KERNEL32.dll + 0x28989 (0x7c598989)

Updated

12 years ago
Severity: normal → critical
(Reporter)

Updated

12 years ago
Keywords: crash
This is the url to bugxula: http://bugxula.mozdev.org/
Component: General → Layout
Product: Firefox → Core
Whiteboard: DUPEME

Comment 2

12 years ago
Bug 326959 has the same signature and has a testcase.
QA Contact: general → layout
(Reporter)

Comment 3

11 years ago

*** This bug has been marked as a duplicate of 326959 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsPopupSetFrame::Destroy]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.