If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Due to splitwindow, window.location != window.document.location

VERIFIED FIXED

Status

()

Core
DOM
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: bz, Assigned: mrbkap)

Tracking

({fixed1.8, regression})

Trunk
x86
Linux
fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8b4 +
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

At the moment, it's possible for us to have a docshell with no document loaded
in it (due to our frame recursion protection or due to the document not having
had time to load yet).  When this happens, for the docshell that doesn't have a
document loaded in it window.location will throw on being set (because there is
no inner window).  If window.document.location is set instead, things work,
since we synthesize an about:blank document.
Flags: blocking1.8b4?
Keywords: regression
Created attachment 193372 [details]
Simple testcase
So I guess what it comes down to is that we may need to synthesize inner windows
(with an about:blank document) as needed...

Updated

12 years ago
Assignee: general → jst
Flags: blocking1.8b4? → blocking1.8b4+
Fixed by mrbkap, over to him to mark fixed for branches etc.
Assignee: jst → mrbkap

Updated

12 years ago
Flags: blocking1.8b5+
(Assignee)

Comment 4

12 years ago
Fixed on trunk and MOZILLA_1_8_BRANCH by the checkin for bug 304882.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Verified FIXED using build 2005-08-27-05 SeaMonkey trunk on the testcase in
Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.