link doubling after saving html document when using javascript to generate mailto link

RESOLVED DUPLICATE of bug 115328

Status

()

RESOLVED DUPLICATE of bug 115328
13 years ago
10 years ago

People

(Reporter: nightwalker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If a web page contains this javascript code:
--------------------------------------------
<script type="text/javascript">
<!--
	var username = "user";
	var hostname = "domain.com";
	var address = username + "@" + hostname;
	document.write("<a href="+"mail"+"to:"+address+">"+address+"<\/a>")
//-->
</script>
-------------------------------------------------------------------------

and then the document is saved using File > Save Page As dialogue, the saved
page will contain this code:
----------------------------
<script type="text/javascript">
<!--
	var username = "user";
	var hostname = "domain.com";
	var address = username + "@" + hostname;
	document.write("<a href="+"mail"+"to:"+address+">"+address+"<\/a>")
//-->
</script><a href="mailto:user@domain.com">user@domain.com</a>
-------------------------------------------------------------

In the saved page will appear the original javascript code and it's result,
which leads to the mailto link being displayed two times.

Reproducible: Always

Steps to Reproduce:
1. Include javascript mentioned above in a page.
2. Use File > Save Page As dialogue to save the page on a harddrive.
3. Open the saved page.

Actual Results:  
You'll see two same links, one after another.

Expected Results:  
Not include the result of javascript in the saved page.
Created attachment 193379 [details]
testcase comment #0

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050821
Firefox/1.0+ ID:2005082112

confirming

Comment 2

13 years ago
Duplicate of/related to Core bug 115328 or Core bug 260066?

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 115328 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.