FF won't download file if extension is gz.sh

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Patrick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050811 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050811 Firefox/1.0.6

In the page at
http://www.3dgamers.com/dlexit/intelenet/games/quake3arena/linuxq3ademo-1.11-6.x86.gz.sh.html,
if you try and download the file (This is Firefox 1.0.6 in Gentoo), a dialog
pops up, but a weird combo box shows up at the bottom of the dialog (to choose
whether to save or open the file). If you click the down button, the option is
Other... When you click that, it asks you what program to open the file with.

I tried downloading the file to my harddrive (not opening, saving), I clicked
OK, and the dialog disappeared (as it should) but when looking in the download
manager, FF is not downloading the file.

Reproducible: Always

Steps to Reproduce:
1. Go to
http://www.3dgamers.com/dlexit/intelenet/games/quake3arena/linuxq3ademo-1.11-6.x86.gz.sh.html
2. Click "Click here if the download doesn't start after 5 seconds."
3. A dialog box will open. Choose "Save", click OK. Check download manager

Actual Results:  
Nothing starts to download, download manager doesn't show file wanting to download.

Expected Results:  
File should start to download, download manager should show it.

Comment 1

12 years ago
Confirmed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050823
Firefox/1.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
I got a 403, which just means that access to that particular file is forbidden.  However, Bugzilla history shows me that patrick has since marked this 'fixed'.  Since we can't point to any client-side fix--and we've had many successive Firefox versions since--marking this as worksforme.
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.