packager.mk doesn't leave safe symbolic links alone

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
7 months ago

People

(Reporter: mark, Assigned: mark)

Tracking

({fixed1.8})

Trunk
PowerPC
Mac OS X
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
packager.mk shouldn't interfere with safe symbolic links.  A safe symlink is
relative and points within the tree.  Such links should be preserved in the
packaged dmg rather than copying the link's referent.

rsync has an option, --copy-unsafe-links, which produces the desired behavior. 
It should replace -L (--copy-links) when rsync is used in packager.mk. 
--copy-unsafe-links is used elsewhere in the build (although nowhere that it
would currently make a difference) and is supported in the rsync versions
present on all supported Mac build platforms.

This is causing slight bloat in Camino now that it's moved to the mainstream
packager, because Camino bundles a framework and frameworks are notoriously
populated with all sorts of symlinks pointing within themselves.  This change
will not interfere with other packaged applications, which don't currently
include any safe symlinks.
(Assignee)

Comment 1

13 years ago
Created attachment 193388 [details] [diff] [review]
Patch

If it's all the same to everyone else, I'd like this for 1.8b4.  It's a size
regression for Camino, and the patch is safe.
Attachment #193388 - Flags: review?(benjamin)
Attachment #193388 - Flags: approval1.8b4?

Updated

13 years ago
Attachment #193388 - Flags: review?(benjamin) → review+
(Assignee)

Comment 2

13 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 3

13 years ago
getting this fix on the radar by requesting 1.8b4
Flags: blocking1.8b4?

Updated

13 years ago
Attachment #193388 - Flags: approval1.8b4? → approval1.8b4+

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Updated

13 years ago
Keywords: fixed1.8

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.