EULA in Mac OS X disk image breaks repackaging for localized builds

VERIFIED DUPLICATE of bug 305131

Status

()

--
blocker
VERIFIED DUPLICATE of bug 305131
13 years ago
13 years ago

People

(Reporter: MMx, Assigned: benjamin)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Currently, I do regular builds of German DeerPark (MOZILLA_1_8_BRANCH) because
Maya does not produce any.
Tonight, this build failed obviously because of the new EULA in the disk image.
(It still worked on 2005-08-18)
The diskimage does not get mounted when running "make -C browser/locales
installers-de" because it waits for the EULA to be accepted - Which can't happen
though because the attach options prevent windows from opening.
in the terminal it looks like this:
-------------------------------------
  set -e; unset NEXT_ROOT; mkdir mount-temp; hdiutil attach -readonly
-mountpoint mount-temp -private -noautoopen
/Volumes/6GB_IBM_TEMP/SRC_ROOT_MZ18/mozilla/firefox-objdir/dist/firefox-1.0+.en-US.mac.dmg
> hdi.output; DEV_NAME=`egrep '^/dev' < hdi.output | sed 1q | awk '{print $1}'`;
rsync -a mount-temp/DeerPark.app firefox; hdiutil detach ${DEV_NAME}; 
--------------------------------------
This then sits there until "killall hdiutil".

actual result:
can't repackage to different languages

expected result: 
produce German disk image

Comment 1

13 years ago
-> bug 305131
(Assignee)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 305131 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.