css: box damaged if using overflow: auto

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: dietmar.rabich, Unassigned)

Tracking

(Blocks 1 bug, {testcase})

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

906 bytes, application/xhtml+xml
Details
Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Using several boxes cascading and each box with attribute "overflow: auto" the
border of the boxes differ partially with 1 oder 2 pixels.

Reproducible: Always

Steps to Reproduce:
1. Put the following source in a file, for example test2.xhtml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
<head>
<title>Test Case 2</title>
<style type="text/css">

.frame {border: 1px solid; position: absolute; width: 40%; height: 40%; opacity:
0.3; overflow: auto;}
#test1 {left: 10%; top: 10%;}
#test2 {left: 18%; top: 18%;}
#test3 {left: 26%; top: 26%;}
#test4 {left: 34%; top: 34%;}
#test5 {left: 42%; top: 42%;}
#test6 {left: 50%; top: 50%;}

</style>
</head>
<body>

<div class="frame" id="test1"><p>Test</p></div>
<div class="frame" id="test2"><p>Test</p></div>
<div class="frame" id="test3"><p>Test</p></div>
<div class="frame" id="test4"><p>Test</p></div>
<div class="frame" id="test5"><p>Test</p></div>
<div class="frame" id="test6"><p>Test</p></div>

</body>
</html>

2. Open the file with Firefox
3. Look at the boxes

(If everything looks fine, change the window size.)

Actual Results:  
The border is not a real line. Some parts of the border are not shown or are
displaced.

Expected Results:  
A real line should be shown as border.
Reporter

Comment 1

14 years ago
Posted file The sample file.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
OS: Windows 2000 → All
Keywords: testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed, altough I think I've seen bugs that are related/the same.
This works for me in my debug build with the patch for bug 317375.
Depends on: 317375
Spoke too soon, can also be seen in my debug build.
No longer depends on: 317375
This is very closely related to, if not a dupe of, bug 298219.
Depends on: 298219
The test case here now works correctly as well (similar as bug 298219) - OS X 10.5.4
Daniel, does it work for you ?

Comment 7

11 years ago
It WFM, but is it intended that the borders of the topleft and bottomright boxes do not cross like two single lines in the middle of the page? Instead they form a small node.

May be because percentages are used a lot. Anyway, the brokenness of Fx2 is gone. Fx2 also hand a "node".
I see that same issue with the topleft and bottomright boxes on all browsers: WebKit latest nightly, Safari 3, Opera 9.52. Resizing the window changes that overlap. But it is more rounding issue with percentage width/height/positioning.

Resolving as WFM, as the broken lines as seen in Gecko 1.8.1 is gone.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.