some preferences windows are not wide enough, wrong accesskey for clear private date setttings and prefs title not translated

RESOLVED FIXED

Status

Mozilla Localizations
de / German
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Ronny Perinke, Assigned: atopal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8b4) Gecko/20050819 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8b4) Gecko/20050819 Firefox/1.0+

- the main pref window and the fonts window are to small (also on unix)

- wrong accesskey ->
http://lxr.mozilla.org/l10n/source/de/browser/chrome/browser/preferences/privacy.dtd#55

- not localized title ->
http://lxr.mozilla.org/l10n/source/de/browser/chrome/browser/preferences/preferences.dtd#11

Reproducible: Always

Updated

12 years ago
Assignee: kairo → a.topal
(Reporter)

Comment 1

12 years ago
Created attachment 193436 [details] [diff] [review]
patch

p.s.
for Firefox 1.5 Branch locales of course
Attachment #193436 - Flags: approval-l10n?
(Reporter)

Comment 2

12 years ago
Created attachment 193437 [details]
screenshot

Comment 3

12 years ago
Dupe/related to bug 283697?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Dupe/related to bug 283697?

Making the prefs windows resizable is one thing, but it should not be necessary
by default (with default themes and fonts) to resize them - that's the point.

You need to resize them, if you use other themes and fonts where they are cropded.


p.s.
I just noticed that the findPrevious accesskey of the findbar is wrong, too.
http://lxr.mozilla.org/l10n/source/de/toolkit/chrome/global/findbar.dtd#8
I think we need to look over all the window sizes again, I am also experiencing
a stange behaviour here on Mac...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
QA Contact: mozilla → mmx_bugzilla
Hardware: PC → All
(Assignee)

Comment 6

12 years ago
okay, fixed some of the sizes, but I can't change the height of the security and
the sanitize panel, so the groupbox is chopped off. Changing the value in
preferences.dtd changes the size of the surrounding space only.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

12 years ago
MMx can you tell me the correct sizes for Mac OS X?
Blocks: 307082
sure.

In browser/preferences/preferences.dtd:
<!ENTITY prefWindow.styleMac "width: 52em;">

In browser/preferences/sanitize.dtd:
<!ENTITY window.width "38em">

The latter entity affects Windows and Linux, too. But it has to be wide enough
for the first line of text to fit in one line, otherwise the last option gets
cropped (not only the group box).
another 3 items I found:

in browser/preferences/languages.dtd
<!ENTITY window.width "37em">

in browser/preferences/colors.dtd
<!ENTITY window.width "44em">
This entity affects all platforms again, but do we have a choice?

in browser/preferences/fonts.dtd
<!ENTITY window.macWidth "47em">
(Assignee)

Comment 10

12 years ago
Done, but there is still the problem with the cropped groupbox :-/

Updated

12 years ago
Attachment #193436 - Flags: approval-l10n?
Created attachment 196638 [details] [diff] [review]
patch to reflect remaining changes

patch to make the remaining changes. Checked in on BRANCH.
Attachment #193436 - Attachment is obsolete: true
(Assignee)

Comment 12

12 years ago
This is fixed with the latest RC2.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.