If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS :active pseudo-class does nothing in forms

VERIFIED DUPLICATE of bug 35246

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 35246
18 years ago
16 years ago

People

(Reporter: bnb, Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
My reading of the HTML4.0 standard says that the form in 
http://www.looking-glass.org/gallery/ should show an selected element as red
text with a white background.

The CSS request within this page is...

<Style type="text/css">
  BODY { background: black;
         color: white
  }
  FORM   { border: 0px red;margin: 0px 0px }
  SELECT { background: black; color: white; border-color: red } 
  OPTION { background: black; color: white; border-color: red } 
  FORM:active   { background: white; color: red }
  SELECT:active { background: white; color: red } 
  OPTION:active { background: white; color: red }
  .right        { text-align: right; color: white }
</Style>
bnb@looking-glass.org - are you still seeing this problem on recent builds of 
Mozilla?

Gerv

Comment 2

18 years ago
Hmmm... Anyone out there have a good definition about what the :focus and
:active pseudo-classes should mean for options in a select box? The :active one
seems to be hooked up, but not what the author intended here. On the other hand,
if :active is hooked up for an option element, then :focus should be as well.
Currently, only :active is hooked up.

Any takers?

Comment 3

18 years ago
FYI, section 5.11.3 of the CSS2 spec seems to be the clearest definition of
these terms that I can find.
See bug 35246.  This is probably a duplicate, at least in part, but perhaps that
bug should be reopened.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: CSS :active attribute does nothing in forms → CSS :active pseudo-class does nothing in forms

Comment 5

18 years ago
Rod: please comment and/or triage.
Assignee: rickg → rods
(Assignee)

Comment 6

18 years ago
dupping bug as suggested by david, which I agree with his point.

*** This bug has been marked as a duplicate of 35246 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.