Java applet hangs up the browser (and sometimes the computer)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Ted Prowler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When logging in Lavalife.com, the Java applet (its window is located in upper
right corner of the window) cannot start (this happens 1 time out of 3). The
browser stalls. I have to use Task Manager to kill the Firefox process.
Sometimes I even have to reset the computer because the operating system stops
responding.
This lasts since the very first version of Firefox.
Everything works fine under Internet Explorer.
This problem persists since I installed Firefox version 0.9 (now I have 1.0.6)

Reproducible: Always

Steps to Reproduce:
1. Go to Lavalife.com
2. Log in as a user
3. If everything is OK, log out and repeat until the problem occurs

Actual Results:  
The browser (ad sometimes Windows) hangs up

Expected Results:  
It should have started the applet

Updated

13 years ago
Summary: Java applet hangs up the broewser (and sometimes the computer) → Java applet hangs up the browser (and sometimes the computer)
Always include the used JRE Version in your bug report if you report a problem
with Java. (see "about:plugins" as URL for the version).
And did you also try running Firefox in the Firefox safemode ?

(Reporter)

Comment 2

13 years ago
Addition for Matti:

There is no such command in Firefox for Windows.

As for the Java runtime environment (its icon appears in system tray when a page
with Java is loaded), its About dialog says the following:

Java(TM) Runtime Environment, Standard Edition 1.3.1_11
Default Visrual Machine Version 1.3.1_11-b02
Java(TM) Plug-in 1.3.1_11

As I understand, this is the JVM that came with Firefox
There is "about:plugins" in Firefox. Just type it in the URL bar as URL (of
course without the "").
Firefox doesn't come with a JRE or any other kind of plugin.
You JRE is very, very old and contains many bugs (also many security related
bugs). Please download the recent JRE from here :
http://java.com/en/download/windows_xpi.jsp and try it again.

PS: I would suggest that you uninstall the old JRE1.3.X installation before you
install JRE1.5
(Reporter)

Comment 4

13 years ago
Thanks, it seems to work so far. Yet, it takes longer for the applet to start
and the applet takes about 30 MB of RAM when started. With the previous version
of JVM, it was much less RAM-hungry. When I load the same page with Internet
Explorer (I did not choose to install v.5 for IE), the applet takes only 10 MB.
What a monster Java has become! I am afraid I will become an adherent of .Net
And Firefox itself is pretty RAM-hungry. When I start it, it takes about 20 MB,
while IE takes only about 10 MB.
thanks, marking worksforme
Your problem was caused by the JRE Plugin and not Firefox.

>When I start it, it takes about 20 MB,while IE takes only about 10 MB.
That is not true !
Many parts of IE are part of the OS and you don't see the size of this parts
with a process explorer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.