Last Comment Bug 305520 - GtkPromptService invalid warning on ConfirmEx with < 3 buttons
: GtkPromptService invalid warning on ConfirmEx with < 3 buttons
Status: RESOLVED FIXED
: fixed1.8
Product: Core Graveyard
Classification: Graveyard
Component: Embedding: GTK Widget (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Christian Persch (GNOME) (away; not receiving bug mail)
: Stuart Parmenter
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 09:50 PDT by Christian Persch (GNOME) (away; not receiving bug mail)
Modified: 2012-04-05 00:46 PDT (History)
0 users
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (1.02 KB, patch)
2005-08-22 09:51 PDT, Christian Persch (GNOME) (away; not receiving bug mail)
mpgritti: review+
roc: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description Christian Persch (GNOME) (away; not receiving bug mail) 2005-08-22 09:50:36 PDT
Steps to reproduce:
0) run TestGtkEmbed
1) Go to http://foo@gnome.org/

Results:
WARNING: Unexpected button flags, file
/opt/source/mozilla/1.8-ff/mozilla/embedding/browser/gtk/src/GtkPromptService.cpp,
line 346

The 'unexpected' flag is 0. This happens when determining the label of the 3rd
button, and flags is 0 because there are only 2. nsIPromptService.idl for
ConfirmEx says "Puts up a dialog with up to 3 buttons and an optional, labeled
checkbox.", so this is NOT unexpected. Simple fix coming up.
Comment 1 Christian Persch (GNOME) (away; not receiving bug mail) 2005-08-22 09:51:11 PDT
Created attachment 193456 [details] [diff] [review]
fix
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2005-09-15 18:05:01 PDT
Comment on attachment 193456 [details] [diff] [review]
fix

only affects Gtk embedding
Comment 3 Christian :Biesinger (don't email me, ping me on IRC) 2005-09-18 07:04:07 PDT
trunk:
Checking in embedding/browser/gtk/src/GtkPromptService.cpp;
/cvsroot/mozilla/embedding/browser/gtk/src/GtkPromptService.cpp,v  <-- 
GtkPromptService.cpp
new revision: 1.10; previous revision: 1.9
done

MOZILLA_1_8_BRANCH:
Checking in embedding/browser/gtk/src/GtkPromptService.cpp;
/cvsroot/mozilla/embedding/browser/gtk/src/GtkPromptService.cpp,v  <-- 
GtkPromptService.cpp
new revision: 1.8.2.2; previous revision: 1.8.2.1
done

Note You need to log in before you can comment on or make changes to this bug.