Cannot open multiple attachements at once

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: matjaz.bugzilla.2005, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

In 1.0.6 you can select multiple attachements, right click and select "open". In
1.0+ "open" item is disabled if more than one attachement is selected.

Reproducible: Always

Steps to Reproduce:
1. Open an email with more than one attachement.
2. Select more than one attachement (hold down ctrl-key)
3. Right-click
Actual Results:  
"open" menu item is disabled.

Expected Results:  
"open" is enabled.

Comment 1

13 years ago
Reproduced with TB 1.0+0806, Win2K.  This might have been a deliberate change, 
tho.
Severity: normal → minor
OS: Windows XP → Windows 2000
Version: unspecified → Trunk

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: front-end

Updated

10 years ago
Duplicate of this bug: 345447

Comment 3

10 years ago
For the sake of tracking and more, seams to me that:
-It was removed (grayed) on purpose, as the handling was kinda wrong.
According to bug 345447 it happened "After version 1.1A1 (from version 1.1A2)"
-It still stays removed/disabled on TB 2 (tested 2.0.0.16)
-It gets back in 3, bug 345447comment#1 assumes is an open for 1 file and open on several is not working. 

But I'd say seams to try to open 2 jpg attachments and:
-first is opened correctly, called "custo1.jpg", second not
-going in temp folder I see the second "custo2.jpg" under the name v0JXokqj.JPG.part (random each time) for the time the open dialog is on, on closing it dissapears

testing on 
Shredder/3.0a2pre ID:2008072303

My conclusion would be, on trunk id is enabled, but the result is wrong. It's not just opening 1 file, seams to try more but fail somehow. If no correction in time for 3, disabling is a safe solution.

Note: could this be a RFE? I mean it's an ability not there. And some issues may arise if implementing (what if you open 10 big files or more etc..)
Assignee: mscott → nobody
Fixed by bug 630759.

Wfm on TB 17.0.6 / WinXP.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 630759
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.