click a link in thunderbird cannot open a new tab in deer park

RESOLVED DUPLICATE of bug 312154

Status

()

RESOLVED DUPLICATE of bug 312154
14 years ago
13 years ago

People

(Reporter: speedogoo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8b3) Gecko/20050721 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8b3) Gecko/20050721 Firefox/1.0+

I download deerpark-alpha2-sparc-sun-solaris2.10-gtk2+xft+SVG from
ftp.mozilla.org. It works fine but there is a strange thing:

I click a link in thunderbird, a deer park window is opened. Then I click
another link in thunderbird, nothing happens, when I close the 1st deer park
window, a new one is opened.

It seems that the 2nd click has spawn a process which is waiting on some lock
(hold by the 1st one). Instead of asking the 1st process to open a new
window/tab (and then maybe kill itself), it blocks.

Reproducible: Always

Steps to Reproduce:
1. Start thunderbird and find a mail with a link
2. click it and see deer park open
3. find another mail in thunderbird with a link and click it
4. nothing happens
5. close deer park
6. another deer park starts showing the link of 3.

Actual Results:  
6. another deer park starts showing the link of 3.

Expected Results:  
after 3, the link should appear in the existing deer park window (possibly in a
new tab)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050822
Firefox/1.0+ ID:2005082222

WFM in WinXP: three links in Thunderbird open three tabs in Firefox.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050822
> Firefox/1.0+ ID:2005082222
> 
> WFM in WinXP: three links in Thunderbird open three tabs in Firefox.

I know it works fine on Linux and Windows, but *not* on Solaris (at least sparc).
mine is SunOS 5.11 snv_19 sun4u sparc SUNW,Sun-Blade-2500
Is this a mailer bug or a browser bug? I see this (or something similar) on XP too, with TB and Fx (both 1.5 Branch) set up as default mail & Internet apps. I vote for confirming this as All/All, unless what I'm seeing is a different (Windows) bug.

Clicking a link in an email in TB never does anything. Workaround: Use "Launchy" extension in TB, where "Open Link in Firefox" opens a new tab (with my Tab Mix Plus settings) if Fx is already running, or an instance of Fx if it isn't.

Currently using:
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051201 Thunderbird/1.5" - Build ID: 2005120110
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051201 Firefox/1.5" - Build ID:2005120103

Comment 4

13 years ago
The workaround of using "Launchy" + "My Tab Mix" does not resolved the problem on Solaris with Thunderbird_1.0.6/Firefox_1.5. 

This is a serious regression wrt. Firefox 1.0.7.

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 312154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.