If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tr:active is ignored, but tr:hover works

RESOLVED DUPLICATE of bug 65917

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 65917
12 years ago
12 years ago

People

(Reporter: Ximin Luo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Well, I can't elaborate further...

In a CSS (inline or imported), tr:active is ignored, but tr:hover works. :active
works for all other elements.

Reproducible: Always

Steps to Reproduce:
A.Hover over the <tr> in the specified webpage above.
B.Click the <tr>.

Actual Results:  
A.The colour changes according to the CSS rule.
B.The CSS rule is ignored.

Expected Results:  
B.The <tr> should have changed colour just like the <p> element under it.

Comment 1

12 years ago
(In reply to comment #0)

> Steps to Reproduce:
> A.Hover over the <tr> in the specified webpage above.
> B.Click the <tr>.

There don't seem to be any <tr> tags at the address you've provided
(http://webxl.5gigs.com/scratch/, redirects to http://webxl.5gigs.com/#scratch/).

A reduced testcase would be the best.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> (In reply to comment #0)
> 
> > Steps to Reproduce:
> > A.Hover over the <tr> in the specified webpage above.
> > B.Click the <tr>.
> 
> There don't seem to be any <tr> tags at the address you've provided
> (http://webxl.5gigs.com/scratch/, redirects to http://webxl.5gigs.com/#scratch/).
> 
> A reduced testcase would be the best.

I made that page specifically to show this bug... just open the page and you'll
see the buggy table... I don't see what the redirection has to do with anything
- it's automatic, it's on all my pages, but it doesn't affect the viewing of
that page.

If you still can't see it I'll take the redirection off.

 but the buggy table is on that page and displays in my browser.
I can see the bug with Mozilla1.7, but not with the latest nightly trunk build.
Please test again with the latest nightly trunk build:
http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I can see the bug with Mozilla1.7, but not with the latest nightly trunk build.
> Please test again with the latest nightly trunk build:
> http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/

Oh right, well I am still using firefox 1.0.6, the public release.
Just to make sure, do you mean that the tables light up (red background, purple
text) when clicked?

And I suppose this means it will be fixed in the next public release, right? :D
(In reply to comment #4)
Yes, to all the questions
Created attachment 193582 [details]
Simple testcase

This is a simple testcase and from it this seems to work for me, clicking on
the table cells turns the background of the row red.
(Reporter)

Comment 7

12 years ago
Yup, tested it with Deer Park Alpha 2 and it works fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 8

12 years ago
Ximin, I missed the iframe :) Anyway, this is fixed in the latest trunk builds.
It should also be fixed in the Deer Park Alpha release, the problem was actually
resolved for over a year ago in bug 65917 (but the fix wasn't merged into the 
1.7 branch, ie the code that the Firefox 1.0.x versions is based upon).

*** This bug has been marked as a duplicate of 65917 ***

*** This bug has been marked as a duplicate of 65917 ***
Resolution: FIXED → DUPLICATE
You need to log in before you can comment on or make changes to this bug.