Closed Bug 305632 Opened 15 years ago Closed 15 years ago

Throbber not working

Categories

(Core :: Web Painting, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED

People

(Reporter: stevee, Assigned: vlad)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050822
Firefox/1.6a1 ID:2005082221

The throbber does not seem to be working anymore. It is not displayed on my
menubar where it usually is, and does not appear as the favicon in the tabs when
reloading them.

1. New Profile, run firefox.
2. Open 2 or more tabs.
3. Refresh one of the tabs

Expected: Animated throbber in place of the tab's favicon whilst tab is reloading
Actual: Whilst tab refreshing: No throbber shown, no favicon shown
WFM om mac:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050823
Firefox/1.6a1
Alfred, any chance you could look into this regression?  Might it be fallout
from bug 285872?
Looks like any rendering with opacity < 1 is broken.  Vlad touched this code,
apparently...
Assignee: nobody → roc
Component: General → Layout: View Rendering
Product: Firefox → Core
QA Contact: general → ian
Assignee: roc → vladimir
Flags: blocking1.9a1+
OS: Windows 2000 → All
Hardware: PC → All
(In reply to comment #3)
> Looks like any rendering with opacity < 1 is broken.  Vlad touched this code,
> apparently...

Confirmed.  Overriding the opacity back to 1 on a previously less-than-opaque
element, however, will indeed make it show again.
*** Bug 305685 has been marked as a duplicate of this bug. ***
PUSH/POP won't ever be set on the same element, so tracking usingBuffers within
the function does us no good.  Just check whether Push/Pop succeeded.
Attachment #193659 - Flags: review?(roc)
Comment on attachment 193659 [details] [diff] [review]
fix transparency in view manager

You need the NS_ASSERTION(aRCSurface and if (aRCSurface) test in the Pop path.
Attachment #193659 - Flags: superreview+
Attachment #193659 - Flags: review?(roc)
Attachment #193659 - Flags: review+
Checked in.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050824 Firefox/1.6a1

which I got from Pacifica:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/pacifica-trunk

firefox-1.6a1.en-US.win32.installer.exe         4805 KB         8/25/2004      
3:44:00 AM
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.