Attachments that contain accent fails are corrupted: the file received has no extension and is named 'unnamed'

VERIFIED DUPLICATE of bug 309566

Status

VERIFIED DUPLICATE of bug 309566
13 years ago
13 years ago

People

(Reporter: gregorsamsalike, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

The filename is ok in the 'Sent' directory of Tb but corrupted in the recipient
mailbox.

Reproducible: Always

Steps to Reproduce:
1. Attach a file which name contains an accent (é, è, û, ...) by any method
(from the compose window or by 'drag & drop')
2. Send file
3. Open the mail from the recipient webmail or mail client

Actual Results:  
The filename is changed to 'unnamed' without extension. Adding the original
extension allows opening the file. 

Expected Results:  
The file should keep its correct name with accents.
(Reporter)

Comment 1

13 years ago
Bug experienced with version 1.0+ (20050822) with Win XP SP1 and Mac OS X (10.4.2)

Comment 2

13 years ago
Can't reproduce on linux (branch 20050824).
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Can't reproduce on linux (branch 20050824).

Bug still present with branch 20050828 (win XP SP1). Am I alone to experience it ?

Comment 4

13 years ago
works fine for me on WinXP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050907
Thunderbird/1.4 ID:2005090710
(Reporter)

Comment 5

13 years ago
It's important to notice that this bug occurs only when ones tries to open the
attachment from another mail client or from webmail. It doesn't occur in Tb's
interface. The incorrect filename is "file.bin" or "unnamed" without extension.
I can reproduce it with Thunderbird/1.4 ID:2005090710.

Comment 6

13 years ago
This bug accures when attached file is named with צהו.

When attaching the exact same file, without צ ה ו, the filename is correct when reciveing it though.

I am now using Thunderbird 1.5 (20051201) WinXP SP2.
Files are here renamed to: ATT000001.pdf (correct extension, but filename is changed)

In earlier versions of TB rc1 and rc2 the problem was even larger.
Attached files were then renamed to ATT00001.dat (whatever extension original filename had, it was renamed to .dat)

Filenamechange accured when reciveing the mails in Microsoft Outlook Express 6, and webmail.
When sending and reciving mails in Thunderbird, the filename match original filename.

Comment 7

13 years ago
This appears to be a duplicate of bug 309566 (rather than depending on it).
Gregor Samsa, if you agree, please mark this bug as a dupe.
(Reporter)

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 309566 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer depends on: 309566

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.