Closed Bug 305651 Opened 19 years ago Closed 19 years ago

Chatzilla extension does not work

Categories

(Firefox :: General, defect)

1.5.0.x Branch
x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: wgianopoulos, Unassigned)

References

Details

(Keywords: verified1.8)

The chatzilla extension no longer works with the latest Firefox trunk nightly

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050823
Firefox/1.6a1

It produces the folwoing error:

TypeError: attribs has no properties @
<chrome://chatzilla/content/lib/js/menu-manager.js> 587
+ message (string) 'attribs has no properties'
+ fileName (string) 'chrome://chatzilla/content/lib/js/menu-manager.js'
+ lineNumber (number) 587
+ stack (string) 655 chars
+ name (string) 'TypeError'
*

I suspect this may be caused by the checkin for bug 305291, so this could be
filed under the wrong product.
Also broken on branch:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050823
Firefox/1.0+
If it is indeed broken on the branch as well, it must have been a different
checkin that cuased the regression.
Verifying problem is in branch also.
Severity: normal → major
Flags: blocking1.8b4?
Keywords: regression
Version: Trunk → 1.5 Branch
Fixed by followup fix for bug 292731?  Can somone check and close if so?

/be
Depends on: 292731
(In reply to comment #4)
> Fixed by followup fix for bug 292731?  Can somone check and close if so?
> 
> /be

Verified that chatzilla works with the latest trunk tinderbox build.  Marking fixed.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
waiting for verification on branch
I wouldn't wait too long, xpcnativewrappers has just hosed half of the tree.
You'll need a build before 8am today if you want to verify this bug.
Verified on branch as well using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050825
Firefox/1.0+
Status: RESOLVED → VERIFIED
Keywords: regressionverified1.8
Flags: blocking1.8b4?
*** Bug 306425 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.