Problems redrawing bottom margin

RESOLVED DUPLICATE of bug 305673

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 305673
12 years ago
12 years ago

People

(Reporter: Ximin Luo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

When a margin is set dynamically (using JS), the bottom margin is not redrawn.

More specifically: when a (?CSS class)? is added to a (?block-level) element

I havent tested setting the margin directly yet, nor testing it on inline elements

Reproducible: Always

Steps to Reproduce:
1.Go to http://webxl.5gigs.com/scratch/bugtest.html
2.Type "t6" into the top text-box and click "addClass"

Actual Results:  
3.Notice the lack of a bottom margin on the test <div>
4.Click the left link.
5.Then, click the right link.

Notice that the left link is static, and does not fix the re-draw. However the
right link is repositioned on :active and this also re-draws the bottom margin.


Expected Results:  
After 2), the bottom margin should have been redrawn and a 20px gap appear
between the bottom white border and the links.
(Reporter)

Comment 1

12 years ago
Further information:

Bug doesn't show up for inline elements (partly because the vertical margins are
not set)

Bug DOES show up when setting the margin directly. (see updated page)

Bug is ONLY fixed when :active is repositioned; Positioning the static link
doesn't work.

http://webxl.5gigs.com/scratch/bugtest.html#
(Reporter)

Comment 2

12 years ago
Whoops, sorry for submitting that three times.... :blush:
I got confused and pressed forward too many times I think...

*** This bug has been marked as a duplicate of 305673 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.