If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

iframe has a stubborn "default" size

RESOLVED INVALID

Status

()

Core
Layout: HTML Frames
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: billyswong, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

I've never thought iframe has default size.  But there is.  And sometimes
workarounds give you a result stranger than you can imagine.

See attachments.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 193649 [details]
iframe only
(Reporter)

Comment 2

12 years ago
Created attachment 193650 [details]
iframe (width="100%" height="100%"), scrollbar appear outside
(Reporter)

Comment 3

12 years ago
Created attachment 193652 [details]
01 with <div> wrapped, no difference
(Reporter)

Comment 4

12 years ago
Created attachment 193654 [details]
use table to wrap instead, back to layout 00
(Reporter)

Comment 5

12 years ago
Created attachment 193655 [details]
add width="100%" height="100%" to table too, best workaround
(Reporter)

Comment 6

12 years ago
Created attachment 193656 [details]
02 and 04 combined... must be a bug
(Reporter)

Updated

12 years ago
Flags: testcase?
(Reporter)

Comment 7

12 years ago
seems that this bug covers both bug 73464 and 253363
This is invalid; the default size of the iframe is there for compat reasons and because using an intrinsic size of 0 would be silly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> This is invalid; the default size of the iframe is there for compat reasons and
> because using an intrinsic size of 0 would be silly.
> 

The bug is not at example00.  (I can stand that.)  It is at the strange interaction when different elements are added into example00, either in hope of counteracting the default size, or unintentionally inside a actual website.  The way iframe was treated is out of normal people's imagination.  (and broke websites)

In example01, iframe expand to fill the screen.  (and add a strange scrollbar to the page outside)  But in example03, just a table outside undo the effect of "width=100% height=100%"!   What happen in the last example is even crazier!  This is something even "default size" cannot explain!  I really think this is a bug!

(Calmed down) I can feel that this bug is very hard to fix, being a design problem in gecko engine...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
All your tests are in quirks mode; those behaviors are correct in that mode and needed for compat with sites authored to bugs in IE and Netscape 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> All your tests are in quirks mode; those behaviors are correct in that mode and
> needed for compat with sites authored to bugs in IE and Netscape 4.
> 

Correct? You say what I see in the tests is correct? Even if those scrollbars don't appear in IE? (Well, there's always a scrollbar at the right in IE, but it remain gray-out, which is what it should be) It is correct even when the iframe in the last test expand horizontally but not vertically in Fx, and Fx only?  Or do you mean this is my computer's problem and you don't see the same thing happen on your machine?  (I have upgraded to Firefox1.5)

I added loose.dtd to the last test and the iframe's height is still the same. No help. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 12

12 years ago
Created attachment 205227 [details]
what I see in the last test

Feel free to tell me if you still don't see it as a bug when the same thing doesn't happen in IE6.
I mean "correct" in that the code we have gives us maximal compat with IE on most sites with minimal deviation from the CSS standards.  Again, the behavior is as-desired.

> I added loose.dtd to the last test and the iframe's height is still the same.
> No help. 

In standards mode, the iframe height should be the default height in every single one of these testcases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
For what it's worth, your last testcase may indeed show an issue in table sizing in general; it may be worth filing a separate bug on that (since I bet it has nothing to do with iframes and should be reproducible if the iframe is replaced with a div).

Updated

11 years ago
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.