No New Mail Sound Ever Heard

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: amtor, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; DFAIT; .NET CLR 1.1.4322)
Build Identifier: 

I just bought a new Powerbook with Tiger and installed a number of Apple 
updates. I have created three user accounts. 

I installed Thunderbird v1.06. When new mail arrives, I do not hear the new 
mail sound.  I even tried changing the new mail sound to a custom WAV file.  
Again no new mail sound is ever heard.  Even if I click on PREVIEW in the 
preferences, I never hear a sound. 

I know the sound system is working. I can run iTuens and hear music. 

To make matters worse, the same problem is occuring when the Apple mail 
program is run but only for the user which is set up to use Thunderbird.  I am 
not sure whether Thunderbird is changing any of the audio settings when it is 
installed and set up for a particular user.

Any thoughts?

Rob



Reproducible: Always

Steps to Reproduce:
1. Setup multiple user accounts in Mac OS X
2. Install Thunderbird v1.06
3. When the install/account wizard to set up an account for ONE user
4. Send an Email to this user
5. Mail arrives but NO new mail sound is heard in Thunderbird
6. Run iTunes - Music is heard!
7. Close and exit Thunderbird
8. Open Apple Mail
9. Send mail to this user
10. Mail arrives but no new mail sound is heard
11. Log into another user account
12. Run Apple Mail
13. Send mail to this user
14. Mail Arrives and new mail sound is heard.

Actual Results:  
Mail arrives but NO new mail sound is heard in Thunderbird for this user.

When using the Apple Mail program, the no new mail sound is also NOT heard BUT 
just for this one user.

Expected Results:  
New Mail sound should be heard in speakers when using EITHER Thunderbird or 
Apple Mail.  It looks like Thunderbird may be also breaking Apple Mail as well.

Comment 1

13 years ago
(In reply to comment #0)
 
> I even tried changing the new mail sound to a custom WAV file.  
> Again no new mail sound is ever heard.  Even if I click on PREVIEW in the 
> preferences, I never hear a sound. 

That's bug 194632.

(Reporter)

Comment 2

13 years ago
I am sure this bug is related to bug 194632 but in my case I never get ANY 
sound not even a system beep.  What is worse it looks like installing 
Thunderbird also breaks sound in other applications like Apple Mail.  Now I 
don't even get a new sound in Apple mail!

I am sure Thunderbird is the cuprit. My Apple is brand new.  The only other 
applications I have installed is Mozilla, Firefox, NeoOffice and Thunderbird. 
The problem started when I installed Thuinderbird for one user on my Apple.  
The other users which have NOT been set up to use Thunderbird are not 
experiencing any problems.  Apple Mail gives the new mail sound.

This bug in Thunderbird may be a trap that other developers have fallen into.  
Apple has a good post on the problem and the solution -- See  
http://docs.info.apple.com/article.html?artnum=300832

Rob
QA Contact: general
WFM on Mac OS X Leopard, Thunderbird 2.0.0.12.

I hear a "beep" sound when I receive new mail. Please feel free to comment if the problem still occurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.