Report A Broken Web Site, Privacy Policy link not working

VERIFIED FIXED

Status

Other Applications
Reporter
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Sean Hayward, Assigned: Gavin)

Tracking

({verified1.8})

unspecified
verified1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050824 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050824 Firefox/1.0+

The "Privacy Policy" hyperlink on the "Fill out Report" form of the "Report A
Broken Web Site..." feature, does not work.


. Nothing will happen

Reproducible: Always

Steps to Reproduce:
1.Help --> Report A Broken Web Site...
2.Accept the Privacy Policy (if you haven't before).
3.Then once the "Fill out Report" form is reached click the "Privacy Policy"
hyperlink, below the "Email (Optional)" textbox.

Actual Results:  
Nothing

Expected Results:  
Privacy Policy should have appeared.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050824
Firefox/1.0+ ID:2005082419

I see the same.

Comment 2

13 years ago
Moving to Other Apps:Reporter
Assignee: nobody → robert
Component: General → Reporter
Product: Firefox → Other Applications
QA Contact: general → xul-client

Comment 3

13 years ago
Duplicate of bug 302619?
(Reporter)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 302619 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Please don't file cyclical dups (this is duped to 305794, which is duped to this
bug)!!!

Aaron: this appears to be your work:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/extensions/reporter/resources/content/reporter&command=DIFF_FRAMESET&file=reportWizard.xul&rev2=1.10&rev1=1.9

Seems to effect branch/trunk.  If you can get to this soon with a remedy I'd
appreciate it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Assignee: robert → gavin.sharp
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Created attachment 193826 [details] [diff] [review]
patch
Attachment #193826 - Flags: review?(mconnor)
Comment on attachment 193826 [details] [diff] [review]
patch

I could have sworn I saw this change made already, but I guess we missed this
one.
Attachment #193826 - Flags: review?(mconnor) → review+
Comment on attachment 193826 [details] [diff] [review]
patch

Simple fix, makes Reporter's privacy policy link work.
Attachment #193826 - Flags: approval1.8b4?
Thanks gavin for taking care of this, and dealing with my misreading of this
patch.  And a special thanks to a bad IDE controller for confusing the living
heck out of me.

Updated

13 years ago
Attachment #193826 - Flags: approval1.8b4? → approval1.8b4+

Updated

13 years ago
Flags: blocking1.8b4+
Trunk:
mozilla/extensions/reporter/resources/content/reporter/reportWizard.js;
new revision: 1.23;

1.8 Branch:
mozilla/extensions/reporter/resources/content/reporter/reportWizard.js;
new revision: 1.22.2.1;
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed1.8 → verified1.8
You need to log in before you can comment on or make changes to this bug.