Context Menu on Bookmark right-click is dead

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: JudyLambert, Assigned: Aaron Leventhal)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050824 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050824 Firefox/1.6a1

If you right-click on a bookmark. the context menu that appears, is dead. 
Nothing you click on works.

Reproducible: Always

Steps to Reproduce:
1.Right-click on a bookmark
2.Select any item from the menu that appears
3.Nothing happens

Actual Results:  
Something should happen

Expected Results:  
Whatever you clicked on 

2005082412 Firefox Trunk build
Confirmed. No problem on branch, I guess?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 2

12 years ago
Confirmed in Win 95.  Latest trunk 2005082501

Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.9a1) Gecko/2005082501 Firefox/1.6a1
*** Bug 305933 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
No problem on 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050823
Firefox/1.6a1 ID:2005082308 ,
but context menu for bookmarks is broken on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050824
Firefox/1.6a1 ID:2005082412

Comment 5

12 years ago
This is fallout from bug 303620

Updated

12 years ago
Blocks: 303620
*** Bug 306059 has been marked as a duplicate of this bug. ***
*** Bug 306100 has been marked as a duplicate of this bug. ***
*** Bug 306257 has been marked as a duplicate of this bug. ***
*** Bug 306292 has been marked as a duplicate of this bug. ***
Copying in the patch author and reviewers from bug 303620 as per comment 5.

Comment 11

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050827 Firefox/1.6a1
ID:2005082708

Seeing this on Linux as well.
Keywords: regression
OS: Windows XP → All
WFM, in the latest trunk Firefox and SeaMonkey (gtk2) on Linux.
*** Bug 306407 has been marked as a duplicate of this bug. ***
*** Bug 306414 has been marked as a duplicate of this bug. ***
*** Bug 306454 has been marked as a duplicate of this bug. ***
*** Bug 306457 has been marked as a duplicate of this bug. ***

Comment 17

12 years ago
*** Bug 303992 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
Aaron, we need a fix for this ASAP. It's blocking testing of fixes we need on
the branch.
Assignee: nobody → aaronleventhal
(Assignee)

Comment 19

12 years ago
If this is happening on branch then it's not caused by the fix for bug 303620.
(Reporter)

Comment 20

12 years ago
It's not happening on the branch.
(Assignee)

Comment 21

12 years ago
(In reply to comment #18)
> Aaron, we need a fix for this ASAP. It's blocking testing of fixes we need on
> the branch.

This makes no sense. How is this blocking anything on the branch?
Because if it's broken on the trunk, then drivers@ can't insist that other
bookmark-related patches get testing on the trunk before they land on the branch.
Timo said in bug 305840 comment 30 that one version of the "additional patch"
fixed this bug. I have just checked in the final version of that patch.

Comment 24

12 years ago
I can confirm it's fixed on build 2005083014 (trunk).

Comment 25

12 years ago
Looks like I missed one case, the context menu seems to be still broken if you
don't have bookmarks toolbar or bookmarks toolbar content visible.
Timo - comment 25, isn't that bug 246158?

Comment 27

12 years ago
I don't think so, the first comment in bug 246158 says that the context menu is
empty and filled with gray squares. In this case the menu opens like it should
but the menu items are dead (like they were always before the 'additional' patch
was checked in from bug 305840). This doesn't produce any errors in javascript
console either.

To reproduce:

1) Open Customize Toolbar
2) Drag Bookmarks Toolbar Items to the Customize Toolbar
3) Open bookmarks menu and right click a folder or a bookmark
4) Click any of the context menu items
(Assignee)

Comment 28

12 years ago
(In reply to comment #27)
> To reproduce:
> 
> 1) Open Customize Toolbar
> 2) Drag Bookmarks Toolbar Items to the Customize Toolbar
> 3) Open bookmarks menu and right click a folder or a bookmark
> 4) Click any of the context menu items

In #3 do you mean the bookmarks sidebar?

I'm not seeing this happen.
(Assignee)

Comment 29

12 years ago
I can reproduce that testcase now.
(Assignee)

Comment 30

12 years ago
Created attachment 194546 [details] [diff] [review]
Remove some problematic ::IsFocusable() requirements for XUL

This still leaves more of a visibility check than we had previously.

Mats, feel free to look into this in more detail if you want to save those
checks, but I think we should take them out for now since they are causing
problems, and fixes for branch need to be verified against the trunk.
Attachment #194546 - Flags: superreview?(bryner)
Attachment #194546 - Flags: review?(mats.palmgren)
Comment on attachment 194546 [details] [diff] [review]
Remove some problematic ::IsFocusable() requirements for XUL

Yeah, that's probably best for now. Please add a XXX comment
saying it allows to much but is needed for this bug.
I'll look into this in more detail when time allows.
r=mats
Attachment #194546 - Flags: review?(mats.palmgren) → review+
Comment on attachment 194546 [details] [diff] [review]
Remove some problematic ::IsFocusable() requirements for XUL

... and remove the 'tabIndex' variable too.
Attachment #194546 - Flags: superreview?(bryner) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 33

12 years ago
*** Bug 307931 has been marked as a duplicate of this bug. ***

Comment 34

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050910 Firefox/1.6a1
ID:2005091012

This still isn't fixed on Linux nor Windows (bug 307931) when using comment 27's
steps to reproduce.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 35

12 years ago
Okay. Turns out comment 27 is describing bug 246158. Sorry for the bugspam.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.