DOM inspector "DOM Nodes" option does not appear to work

RESOLVED WORKSFORME

Status

Other Applications
DOM Inspector
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Edward Cruz, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

In the DOM Inspector, after you load a URL to inspect, clicking on DOM Nodes
displays the DOM Node headers titles (nodeName, localName, etc.), but NO Node
data whatsoever.  The Text description of the option selected also does not
refresh to say "DOM Nodes" or similar.

Reproducible: Always

Steps to Reproduce:
1. Launch the DOM Inspector (Tools -> Dom Inspector)
2. Enter a URL (i.e. http://www.firefox.com) and click "Inspect".
2.  There are three view options available:  DOM Nodes, Stylesheet, and
Javascript Object.
3. Select Stylesheet.  This displays the list of stylesheets in the left frame,
and selecting one of the stylesheets displays corresponding data in the right
frame as expected.  Also the text adjacent to the view pulldown now says
"Document - Stylesheets")
4. Select DOM Nodes from the view pulldown on the left. 
Actual Results:  
This displays the DOM Node column titles (nodeName, localName, etc.), but NO
Node data whatsoever.  The Text description of the option selected also does not
refresh to say "Document - DOM Nodes" or similar.


Expected Results:  
I would have expected it to display the hierarchy of document element, starting
with #document as the root.

This seemed like such a fundamental problem I assumed that this was due to my
not understanding how to use the tool.  After finding no reference to a bug like
this, plus several tutorials that illustrated how the DOM Inspector should work,
I concluded that it might actually be a bug...

Comment 1

13 years ago
The "missing Node data" part of this bug is reproducible with Mozilla 1.8b1 and
Deep Park a2 but the description does change back to "Document - DOM Nodes" as
expected. WFM with SeaMonkey/20050822, fixed by bug 251274?

Comment 2

13 years ago
Reporter: can you still reproduce this problem using Firefox 1.5 beta?
Assignee: nobody → dom-inspector
Component: General → DOM Inspector
Product: Firefox → Other Applications
QA Contact: general → timeless
Version: unspecified → 1.7 Branch
(Reporter)

Comment 3

13 years ago
This problem appears to be fixed in Firefox 1.0.7.  Not sure about Beta 1.5. 
Is this an issue with a trunk build?
(In reply to comment #4)
> Is this an issue with a trunk build?

No, WFM, and with other comments indicating the same for older builds, changing status to resolved: worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.