Bullets in list appear overtop of text

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: togepi666, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When viewing this page in M14, bullets appeared overtop of text in a list.

I took a screen shot to show you what I mean:
http://untitled.gif.spacebar.org/bug.gif.

The page also renders awkwardly in Netscape 4.7 -- but it doesn't have bullets
overtop of text.
NS 4.7 doesn't display the bullets at all. The culprit is:
    <li style="text-indent:-.25in">
Note the negative value. So, what Moz is doing does seem sensible to me, but we 
just need someone who knows what's going on here to check that this in fact 
correct behaviour.

Small test case attached.

trying HTMLElement as a first stab at the correct component.

Gerv
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Element
Ever confirmed: true
Keywords: testcase

Comment 3

19 years ago
reassigning to html element
Assignee: cbegle → rickg
QA Contact: asadotzler → petersen

Comment 4

19 years ago
Mark: I don't think this is a bug. CSS let's you reposition text, but it doesn't 
say anything about the bullet. I'd mark this invalid. Please advise.
Assignee: rickg → attinasi
(Assignee)

Comment 5

18 years ago
When you specify a negative text-align it will move the text to the left, 
possibly overlapping the bullet. This is correct behavior. If you want to move 
the entire LI left, including the bullet, try another technique like aligning 
with tables, or using more sophisticated positioning like 'position:absolute'. 

For completness I'm attaching a testcase showing various negative alignment 
values. 

Note that IE5 does move the entire LI, including the bullet, however this is 
incorrect according to the CSS spec. See sections 12.6 and 16.1

I'm marking this bug INVALID because it is not a bug in Mozilla.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 6

18 years ago
Created attachment 6723 [details]
Testcase showing various text-indent values and their results

Comment 7

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 8

18 years ago
Somehow I disagree with how CSS handles this, but on the other hand we're not 
here to change the standards...unless it really suits us. (jk)  Marking verified 
INVALID.  Let me know if you disagree.  I'm sure you will:).
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.