If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

-profile command-line option silently fails if profile missing

VERIFIED DUPLICATE of bug 278860

Status

()

Toolkit
Startup and Profile System
VERIFIED DUPLICATE of bug 278860
12 years ago
9 years ago

People

(Reporter: Josh Kelley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Running Firefox 1.0.6 or Thunderbird 1.0.6 with the -profile command-line option
silently fails if the directory specified is missing.

Reproducible: Always

Steps to Reproduce:
1. Run firefox.exe -profile c:\does-not-exist or thunderbird.exe -profile
c:\does-not-exist.


Actual Results:  
Nothing.

Expected Results:  
Error message that c:\does-not-exist does not exist.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050825
Firefox/1.6a1 ID:2005082521

I see this too in 1.0.6.
In trunk and branch I do get a message, but the wrong one (the running but not
responding message)

Comment 2

12 years ago
Yeah. Like Ria said, we're still giving the wrong error message in 1.5.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.