Closed Bug 30593 Opened 20 years ago Closed 20 years ago

Strings written to System.err result in modal dialog box with Mozilla and MRJ

Categories

(Core Graveyard :: Java: OJI, defect, P3)

PowerPC
All
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lordpixel, Assigned: modgock)

Details

Java is now working with Mozilla on the Macintosh in the nightlies.
Great work guys :-)

One annoying "feature". Any text written to System.err gets
captured and displayed to the user as a Modal dialog box!
This pretty much makes applets that are doing debugging output
to system.err unusable, as you can't interact with the applet for
all of the dialog boxes coming up.

While this can't be decribed as out of Spec, as there is  no spec for
what System.err should be, its very non-standard behviour.
Since all applet environments to this point have directed System.err and
System.out output to a scrolling and initially hidden console, this
change will break a lot of existing applets because it'l keep
interrupting them.

The programmer may have done bad things like leave debuggig output in
production code, and may be making assumptions he or she shouldn't
about what System.err is, this doesn't mean its a good idea to
make these minor problems into a major issue by handling them differently
in Mozilla to every other browser, inc. Navigator 4.

Is this a temporary solution until you get the console going?

This was the March 4th nightly with the OJI plugin using Apple's MRJ 2.2
as the JVM (enough TLAs for you? :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is due to no console window being tied in; the behaviour also occurs for 
System.out as well.

Will investigate.
Assignee: drapeau → modgock
changing status to assigned.
Status: NEW → ASSIGNED
Ok, this has been fixed; it was half fixed before (see below concerning the java 
console).  The short of it is that i removed the modal windows; any output to 
System.out or System.err will get written to a file in the Preferences folder 
called "MRJPluginAppletOutput".  This file will be overwritten each time the 
browser is started AND an applet is loaded AND that applet actually writes out to 
either System.err or System.out.

That being said, there is a way to have a java console as well; this is going to 
make more installation issues.  I will mail out to all people on this bug list 
and cc leaf as he'll need to receive more deliverables.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Updating QA Contact
OS: All
QA Contact: paw → shrir
mac Oji Qa: junruh
QA Contact: shrir → junruh
Verified on the 11/27 Mac trunk build.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.