lib/browserconfig.properties is installed as a symlink to version in build dir, not as an actual file

RESOLVED FIXED

Status

()

Firefox
Build Config
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Hanspeter Niederstrasser, Assigned: Hanspeter Niederstrasser)

Tracking

({fixed1.8})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Using a MOZILLA_1_8_BRANCH firefox CVS tree pulled today, the file
mozilla/browser/base/content/browserconfig.properties is installed as a symlink
that points to the file in the build dir.  This does NOT happen in 1.0.6 under
identical build conditions.  A 1.0.6 install includes the actual file.

The exact install command from the build log for the 1.8 branch build is
**
/sw/src/fink.build/firefox-trunk-1.1-11/mozilla/config/nsinstall -L
/sw/src/fink.build/firefox-trunk-1.1-11/mozilla/browser/base
./content/browserconfig.properties ../../dist/bin
**

This install command is not seen in the 1.0.6 build log.

The relevant file seems to be mozilla/browser/base/Makefile.in, which was
changed from using a perl preprocessor to config/nsinstall around the time this
started (see bug 282057).

Reproducible: Always
(Assignee)

Comment 1

13 years ago
Created attachment 193980 [details] [diff] [review]
makes browserconfig.properties be a file and not a symlink

changes the dangling symlink to be an actual file
Attachment #193980 - Flags: review?(benjamin)
(Assignee)

Comment 2

13 years ago
Should point out that this is in both trunk and in MOZILLA_1_8_BRANCH builds.

Updated

13 years ago
Attachment #193980 - Flags: review?(benjamin)
Attachment #193980 - Flags: review+
Attachment #193980 - Flags: approval1.8b4+
Assignee: nobody → niederstrasser
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Keywords: fixed1.8
(Assignee)

Comment 3

13 years ago
Fixed on a fresh branch CVS pull.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.