Crash when visiting page on rft.com [@ nsGlobalWindow::RunTimeout() ]

RESOLVED DUPLICATE of bug 305452

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 305452
13 years ago
13 years ago

People

(Reporter: Scott Gifford, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Visiting this page reliably crashes Firefox build 20050823 for me:

    http://www.rft.com/appcommercial/pinpoint.htm

TalkBack ID is TB8714783G (I think; I'm not exactly sure how to get TalkBack IDs
nowadays).
Summary: Crash when visiting page on rft.com → Crash when visiting page on rft.com [@ nsGlobalWindow::RunTimeout() ]
Stack Signature	 nsGlobalWindow::RunTimeout() 10b2b79c
Product ID	Firefox15
Build ID	2005082305
Trigger Time	2005-08-25 12:36:32.0
Platform	LinuxIntel
Operating System	Linux 2.6.10-1.12_FC2customsg1
Module	firefox-bin + (0038c258)
URL visited	http://www.rft.com/...
User Comments	Clicked on a link
Since Last Crash	3 sec
Total Uptime	3 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.
/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 848
Stack Trace 	
nsGlobalWindow::RunTimeout() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 848]
nsGlobalWindow::TimerCallback() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 6413]
nsTimerImpl::Fire() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 395]
handleTimerEvent() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 462]
PL_HandleEvent() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/plevent.c,
line 689]
PL_ProcessPendingEvents() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/plevent.c,
line 623]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsEventQueue.cpp,
line 423]
event_processor_callback() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x4987f (0x0089187f)
libglib-2.0.so.0 + 0x24252 (0x0086c252)
libglib-2.0.so.0 + 0x25348 (0x0086d348)
libglib-2.0.so.0 + 0x25680 (0x0086d680)
libglib-2.0.so.0 + 0x25cc3 (0x0086dcc3)
libgtk-x11-2.0.so.0 + 0x10f923 (0x00cef923)
nsAppShell::Run() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 141]
nsAppStartup::Run() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 146]
XRE_main() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 2324]
main() 
[/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 62]
libc.so.6 + 0x14ad4 (0x00a35ad4)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050825
Firefox/1.0+ ID:2005082512

WFM

Comment 3

13 years ago
see bug 305452
Version: 1.0 Branch → 1.5 Branch
(Reporter)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 305452 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.